package/kernel: move target specific modules to their own target files
[oweals/openwrt.git] / package / kernel / modules / block.mk
index 85a440aa5e4050a2bfe38199cb93d917cc5edcb3..53c8ab3e99d89375b9f889c2d163370764e50053 100644 (file)
@@ -83,52 +83,6 @@ endef
 
 $(eval $(call KernelPackage,ata-artop))
 
-define KernelPackage/ata-octeon-cf
-$(call AddDepends/ata,@TARGET_octeon)
-  TITLE:=Octeon Compact Flash support
-  KCONFIG:=CONFIG_PATA_OCTEON_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf,1)
-endef
-
-define KernelPackage/ata-octeon-cf/description
-  Octeon Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-octeon-cf))
-
-
-define KernelPackage/ata-ixp4xx-cf
-$(call AddDepends/ata,@TARGET_ixp4xx)
-  TITLE:=IXP4XX Compact Flash support
-  KCONFIG:=CONFIG_PATA_IXP4XX_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_ixp4xx_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_ixp4xx_cf,1)
-endef
-
-define KernelPackage/ata-ixp4xx-cf/description
- IXP4XX Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-ixp4xx-cf))
-
-define KernelPackage/ata-rb532-cf
-$(call AddDepends/ata,@TARGET_rb532 @BROKEN)
-  TITLE:=RB532 Compact Flash support
-  KCONFIG:= \
-       CONFIG_PATA_PLATFORM \
-       CONFIG_PATA_RB532
-  FILES:=\
-       $(LINUX_DIR)/drivers/ata/pata_platform.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/ata/pata_rb532_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_platform pata_rb532_cf,1)
-endef
-
-define KernelPackage/ata-rb532-cf/description
-  RB532 Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-rb532-cf))
 
 define KernelPackage/ata-nvidia-sata
 $(call AddDepends/ata,)
@@ -141,21 +95,6 @@ endef
 $(eval $(call KernelPackage,ata-nvidia-sata))
 
 
-define KernelPackage/ata-magicbox-cf
-$(call AddDepends/ata,@TARGET_ppc40x)
-  TITLE:=Magicbox v2/OpenRB Compact flash support
-  KCONFIG:=CONFIG_PATA_MAGICBOX_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_magicbox_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_magicbox_cf,1)
-endef
-
-define KernelPackage/ata-magicbox-cf/description
-  Support for Magicbox v2/OpenRB on-board CF slot.
-endef
-
-$(eval $(call KernelPackage,ata-magicbox-cf))
-
-
 define KernelPackage/ata-pdc202xx-old
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Older Promise PATA controller support
@@ -439,21 +378,6 @@ endef
 $(eval $(call KernelPackage,dm))
 
 
-define KernelPackage/pata-rb153-cf
-$(call AddDepends/ata,@TARGET_adm5120_router_le)
-  TITLE:=RouterBOARD 153 CF Slot support
-  KCONFIG:=CONFIG_PATA_RB153_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_rb153_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,pata_rb153_cf,1)
-endef
-
-define KernelPackage/pata-rb153-cf/description
-  Kernel support for the RouterBoard 153 CF slot.
-endef
-
-$(eval $(call KernelPackage,pata-rb153-cf,1))
-
-
 define KernelPackage/aoe
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ATA over Ethernet support
@@ -468,35 +392,6 @@ endef
 
 $(eval $(call KernelPackage,aoe))
 
-define KernelPackage/ps3vram
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=PS3 Video RAM Storage Driver
-  DEPENDS:=@TARGET_ps3||TARGET_ps3chk
-  KCONFIG:=CONFIG_PS3_VRAM
-  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
-endef
-
-define KernelPackage/ps3vram/description
-  Kernel support for PS3 Video RAM Storage
-endef
-
-$(eval $(call KernelPackage,ps3vram))
-
-define KernelPackage/axonram
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=Axon DDR2 memory device driver
-  DEPENDS:=@TARGET_pxcab
-  KCONFIG:=CONFIG_AXON_RAM
-  FILES:=$(LINUX_DIR)/arch/powerpc/sysdev/axonram.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,01,axonram)
-endef
-
-define KernelPackage/axonram/description
-  Kernel support for Axon DDR2 memory device
-endef
-
-$(eval $(call KernelPackage,axonram))
 
 define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)