package the octeon compact flash driver
[oweals/openwrt.git] / package / kernel / modules / block.mk
index e39bda8aa787b888dde6c32ca8e3697b132f9902..37c1045eea3ba51e0899260f798aec6330d5f409 100644 (file)
@@ -66,6 +66,21 @@ endef
 
 $(eval $(call KernelPackage,ata-artop))
 
+define KernelPackage/ata-octeon-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Octeon Compact Flash support
+  DEPENDS:=kmod-ata-core @TARGET_octeon
+  KCONFIG:=CONFIG_PATA_OCTEON_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf)
+endef
+
+define KernelPackage/ata-octeon-cf/description
+  Octeon Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-octeon-cf))
+
 
 define KernelPackage/ata-ixp4xx-cf
   SUBMENU:=$(BLOCK_MENU)
@@ -117,9 +132,7 @@ define KernelPackage/ata-magicbox-cf
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Magicbox v2/OpenRB Compact flash support (ATA)
   DEPENDS:=@TARGET_ppc40x +kmod-ata-core
-  KCONFIG:=\
-       CONFIG_PATA_MAGICBOX_CF \
-       CONFIG_ATA_SFF=y
+  KCONFIG:=CONFIG_PATA_MAGICBOX_CF
   FILES:=$(LINUX_DIR)/drivers/ata/pata_magicbox_cf.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,41,pata_magicbox_cf)
 endef