fix network devices modules to depend on PCI instead of x86
[oweals/openwrt.git] / package / kernel / modules / 001-depends.mk
index 73dd46b9106663cfe9014850d3ce917f9491e84f..6c493018df2fd926d43c5442afb25da40e20c648 100644 (file)
@@ -18,6 +18,11 @@ define AddDepends/input
 endef
 
 
+define AddDepends/nls
+  DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
+endef
+
+
 define SetDepends/rfkill
   DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
 endef
@@ -25,3 +30,8 @@ endef
 define AddDepends/rfkill
   DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
 endef
+
+
+define AddDepends/rtc
+  DEPENDS+= @RTC_SUPPORT
+endef