mac80211: update brcmfmac to the wireless-drivers-next-for-davem-2015-04-09
[oweals/openwrt.git] / package / kernel / mac80211 / patches / 001-fix_build.patch
index c541985cf3f0d2cc2af886fc210f8f68d4c34ede..818983e06e6c7b97fb881e7de0317f4505907f36 100644 (file)
@@ -1,12 +1,21 @@
 --- a/Makefile
 +++ b/Makefile
+@@ -5,7 +5,7 @@
+ ifeq ($(KERNELRELEASE),)
+ MAKEFLAGS += --no-print-directory
+-SHELL := /bin/bash
++SHELL := /usr/bin/env bash
+ BACKPORT_DIR := $(shell pwd)
+ KMODDIR ?= updates
 @@ -19,6 +19,7 @@ KLIB_BUILD ?= $(KLIB)/build/
  KERNEL_CONFIG := $(KLIB_BUILD)/.config
  KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile
  CONFIG_MD5 := $(shell md5sum $(KERNEL_CONFIG) 2>/dev/null | sed 's/\s.*//')
 +STAMP_KERNEL_CONFIG := .kernel_config_md5_$(CONFIG_MD5)
  
- export KLIB KLIB_BUILD BACKPORT_PWD KMODDIR KMODPATH_ARG
+ export KLIB KLIB_BUILD BACKPORT_DIR KMODDIR KMODPATH_ARG
  
 @@ -36,7 +37,8 @@ mrproper:
        @rm -f .kernel_config_md5 Kconfig.versions Kconfig.kernel
@@ -55,7 +64,7 @@
 -              print=0                                                                 ;\
 -              for v in $$kvers ; do                                                   \
 -                      if [ "$$print" = "1" ] ; then                                   \
--                              echo config BACKPORT_KERNEL_$$(echo $$v | tr . _)       ;\
+-                              echo config KERNEL_$$(echo $$v | tr . _)        ;\
 -                              echo "    def_bool y"                                   ;\
 -                      fi                                                              ;\
 -                      if [ "$$v" = "$$kver" ] ; then print=1 ; fi                     ;\
 +      print=0                                                                 ;\
 +      for v in $$kvers ; do                                                   \
 +              if [ "$$print" = "1" ] ; then                                   \
-+                      echo config BACKPORT_KERNEL_$$(echo $$v | tr . _)       ;\
++                      echo config KERNEL_$$(echo $$v | tr . _)        ;\
 +                      echo "    def_bool y"                                   ;\
 +              fi                                                              ;\
 +              if [ "$$v" = "$$kver" ] ; then print=1 ; fi                     ;\
 +      @$(MAKE) Kconfig.versions
        @$(MAKE) -f Makefile.real "$@"
  
- else
+ .PHONY: defconfig-help
 --- a/Makefile.real
 +++ b/Makefile.real
-@@ -54,7 +54,7 @@ defconfig-%::
+@@ -59,7 +59,7 @@ defconfig-%::
  
  backport-include/backport/autoconf.h: .config Kconfig.versions Kconfig.kernel
        @$(MAKE) oldconfig
        @grep -f .local-symbols .config | (                             \
                echo "#ifndef COMPAT_AUTOCONF_INCLUDED"                 ;\
                echo "#define COMPAT_AUTOCONF_INCLUDED"                 ;\
-@@ -75,7 +75,12 @@ backport-include/backport/autoconf.h: .c
+@@ -80,7 +80,12 @@ backport-include/backport/autoconf.h: .c
                        esac                                            ;\
                done                                                    ;\
                echo "#endif /* COMPAT_AUTOCONF_INCLUDED */"            ;\