modules: echo module was moved between 3.14 and 3.18
[oweals/openwrt.git] / package / kernel / linux / modules / sound.mk
index 964524b0afa2a307d14b7b5f399fbc0dfacebee1..54bc30ac32fae6985ffe11c1a7c0dcdeac63e6be 100644 (file)
@@ -51,7 +51,7 @@ endif
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@AUDIO_SUPPORT
+  DEPENDS:=@AUDIO_SUPPORT +kmod-input-core
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -70,7 +70,6 @@ define KernelPackage/sound-core
        CONFIG_SND_COMPRESS_OFFLOAD
   FILES:=$(SOUNDCORE_FILES)
   AUTOLOAD:=$(call AutoLoad,30,$(SOUNDCORE_LOAD))
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/sound-core/uml
@@ -145,22 +144,6 @@ endef
 $(eval $(call KernelPackage,sound-i8x0))
 
 
-define KernelPackage/sound-cs5535audio
-  TITLE:=CS5535 PCI Controller
-  DEPENDS:=+kmod-ac97
-  KCONFIG:=CONFIG_SND_CS5535AUDIO
-  FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko
-  AUTOLOAD:=$(call AutoLoad,36,snd-cs5535audio)
-  $(call AddDepends/sound)
-endef
-
-define KernelPackage/sound-cs5535audio/description
- Support for the integrated AC97 sound device on olpc
-endef
-
-$(eval $(call KernelPackage,sound-cs5535audio))
-
-
 define KernelPackage/sound-soc-core
   TITLE:=SoC sound support
   DEPENDS:=+kmod-regmap +kmod-ac97
@@ -249,7 +232,7 @@ $(eval $(call KernelPackage,sound-soc-gw_avila))
 
 
 define KernelPackage/pcspkr
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86 +kmod-input-core
   TITLE:=PC speaker support
   KCONFIG:= \
        CONFIG_INPUT_PCSPKR \
@@ -258,7 +241,6 @@ define KernelPackage/pcspkr
        $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
        $(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
   AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
-  $(call AddDepends/input)
   $(call AddDepends/sound)
 endef