kernel: crypto: fix depends in kmod-crypto-hmac
[oweals/openwrt.git] / package / kernel / linux / modules / netfilter.mk
index f64808c1bee56931cc0afc2c0a31f0d529c51a68..3a436ac0c577730536aa2a3273b8848311fb1743 100644 (file)
@@ -171,7 +171,6 @@ endef
 define KernelPackage/ipt-filter/description
  Netfilter (IPv4) kernel modules for packet content inspection
  Includes:
- - layer7
  - string
 endef
 
@@ -229,11 +228,11 @@ IPSET_MODULES:= \
        ipset/ip_set_bitmap_ipmac \
        ipset/ip_set_bitmap_port \
        ipset/ip_set_hash_ip \
-       ipset/ip_set_hash_ipmark@ge3.18 \
+       ipset/ip_set_hash_ipmark \
        ipset/ip_set_hash_ipport \
        ipset/ip_set_hash_ipportip \
        ipset/ip_set_hash_ipportnet \
-       ipset/ip_set_hash_mac@ge3.18 \
+       ipset/ip_set_hash_mac \
        ipset/ip_set_hash_netportnet \
        ipset/ip_set_hash_net \
        ipset/ip_set_hash_netnet \
@@ -461,7 +460,6 @@ define KernelPackage/ipt-tproxy
        CONFIG_NETFILTER_XT_MATCH_SOCKET \
        CONFIG_NETFILTER_XT_TARGET_TPROXY
   FILES:= \
-       $(if $(call kernel_patchver_lt,3.12),$(LINUX_DIR)/net/netfilter/nf_tproxy_core.ko) \
        $(foreach mod,$(IPT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoProbe,$(notdir nf_tproxy_core $(IPT_TPROXY-m)))
   $(call AddDepends/ipt)
@@ -776,7 +774,7 @@ $(eval $(call KernelPackage,nfnetlink-queue))
 define KernelPackage/nf-conntrack-netlink
   TITLE:=Connection tracking netlink interface
   FILES:=$(LINUX_DIR)/net/netfilter/nf_conntrack_netlink.ko
-  KCONFIG:=CONFIG_NF_CT_NETLINK
+  KCONFIG:=CONFIG_NF_CT_NETLINK CONFIG_NF_CONNTRACK_EVENTS=y
   AUTOLOAD:=$(call AutoProbe,nf_conntrack_netlink)
   $(call AddDepends/nfnetlink,+kmod-ipt-conntrack)
 endef