kernel: Make kmod-ixgbe depend on kmod-libphy
[oweals/openwrt.git] / package / kernel / linux / modules / netdevices.mk
index cda453e1bbf4032e5c1ced1d478b3772c42e3f40..5fae027417991bd3fb9184024fdee6dc3172f7ee 100644 (file)
@@ -666,7 +666,7 @@ $(eval $(call KernelPackage,igbvf))
 define KernelPackage/ixgbe
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support
-  DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core
+  DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +LINUX_5_4:kmod-libphy
   KCONFIG:=CONFIG_IXGBE \
     CONFIG_IXGBE_VXLAN=n \
     CONFIG_IXGBE_HWMON=y \