kernel: fix usb-ohci-pci description define
[oweals/openwrt.git] / package / kernel / linux / modules / lib.mk
index cd919ba62e9f6844bc0d45b7308b856a17d0f6f9..9d35e42e24dd721efa7577c27322489492852edf 100644 (file)
@@ -72,7 +72,7 @@ define KernelPackage/lib-crc16
   TITLE:=CRC16 support
   KCONFIG:=CONFIG_CRC16
   FILES:=$(LINUX_DIR)/lib/crc16.ko
-  AUTOLOAD:=$(call AutoProbe,crc16)
+  AUTOLOAD:=$(call AutoLoad,20,crc16,1)
 endef
 
 define KernelPackage/lib-crc16/description
@@ -117,6 +117,25 @@ endef
 $(eval $(call KernelPackage,lib-lzo))
 
 
+define KernelPackage/lib-lz4
+  SUBMENU:=$(LIB_MENU)
+  TITLE:=LZ4 support
+  KCONFIG:= \
+       CONFIG_LZ4_COMPRESS \
+       CONFIG_LZ4_DECOMPRESS
+  FILES:= \
+       $(LINUX_DIR)/lib/lz4/lz4_compress.ko \
+       $(LINUX_DIR)/lib/lz4/lz4_decompress.ko
+  AUTOLOAD:=$(call AutoProbe,lz4_compress lz4_decompress)
+endef
+
+define KernelPackage/lib-lz4/description
+ Kernel module for LZ4 compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-lz4))
+
+
 define KernelPackage/lib-raid6
   SUBMENU:=$(LIB_MENU)
   TITLE:=RAID6 algorithm support