kernel: remove useless AddDepends/crc16 abstraction
[oweals/openwrt.git] / package / kernel / linux / modules / input.mk
index 1daaad3471c7c739c90f6af2f774559ce1cc1f15..2320b051f9f366c6307062561636f26a247e6480 100644 (file)
@@ -27,7 +27,7 @@ define KernelPackage/hid-generic
   TITLE:=Generic HID device support
   KCONFIG:=CONFIG_HID_GENERIC
   FILES:=$(LINUX_DIR)/drivers/hid/hid-generic.ko
-  AUTOLOAD:=$(call AutoLoad,62,hid-generic)
+  AUTOLOAD:=$(call AutoProbe,hid-generic)
   $(call AddDepends/hid)
 endef
 
@@ -42,7 +42,6 @@ define KernelPackage/input-core
   TITLE:=Input device core
   KCONFIG:=CONFIG_INPUT
   FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
-  AUTOLOAD:=$(call AutoLoad,19,input-core,1)
 endef
 
 define KernelPackage/input-core/description
@@ -76,13 +75,16 @@ define KernelPackage/input-gpio-keys
        CONFIG_KEYBOARD_GPIO \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
-  AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
+  AUTOLOAD:=$(call AutoProbe,gpio_keys)
   $(call AddDepends/input)
 endef
 
 define KernelPackage/input-gpio-keys/description
  This driver implements support for buttons connected
  to GPIO pins of various CPUs (and some other chips).
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys))
@@ -96,12 +98,15 @@ define KernelPackage/input-gpio-keys-polled
        CONFIG_KEYBOARD_GPIO_POLLED \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys_polled.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_keys_polled,1)
+  AUTOLOAD:=$(call AutoProbe,gpio_keys_polled,1)
   $(call AddDepends/input)
 endef
 
 define KernelPackage/input-gpio-keys-polled/description
  Kernel module for support polled GPIO keys input device
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys-polled))
@@ -112,7 +117,7 @@ define KernelPackage/input-gpio-encoder
   TITLE:=GPIO rotay encoder
   KCONFIG:=CONFIG_INPUT_GPIO_ROTARY_ENCODER
   FILES:=$(LINUX_DIR)/drivers/input/misc/rotary_encoder.ko
-  AUTOLOAD:=$(call AutoLoad,62,rotary_encoder)
+  AUTOLOAD:=$(call AutoProbe,rotary_encoder)
   $(call AddDepends/input,@GPIO_SUPPORT)
 endef
 
@@ -128,7 +133,7 @@ define KernelPackage/input-joydev
   TITLE:=Joystick device support
   KCONFIG:=CONFIG_INPUT_JOYDEV
   FILES:=$(LINUX_DIR)/drivers/input/joydev.ko
-  AUTOLOAD:=$(call AutoLoad,62,joydev)
+  AUTOLOAD:=$(call AutoProbe,joydev)
   $(call AddDepends/input)
 endef
 
@@ -144,7 +149,6 @@ define KernelPackage/input-polldev
   TITLE:=Polled Input device support
   KCONFIG:=CONFIG_INPUT_POLLDEV
   FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-  AUTOLOAD:=$(call AutoLoad,20,input-polldev,1)
   $(call AddDepends/input)
 endef
 
@@ -159,9 +163,8 @@ define KernelPackage/input-matrixkmap
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Input matrix devices support
   KCONFIG:=CONFIG_INPUT_MATRIXKMAP
-  DEPENDS:=@!LINUX_3_3
   FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
-  AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
+  AUTOLOAD:=$(call AutoProbe,matrix-keymap)
   $(call AddDepends/input)
 endef
 
@@ -186,3 +189,21 @@ define KernelPackage/acpi-button/description
 endef
 
 $(eval $(call KernelPackage,acpi-button))
+
+
+define KernelPackage/keyboard-imx
+  SUBMENU:=$(INPUT_MODULES_MENU)
+  TITLE:=IMX keypad support
+  DEPENDS:=@(TARGET_mxs||TARGET_imx6) +kmod-input-matrixkmap
+  KCONFIG:= \
+       CONFIG_KEYBOARD_IMX \
+       CONFIG_INPUT_KEYBOARD=y
+  FILES:=$(LINUX_DIR)/drivers/input/keyboard/imx_keypad.ko
+  AUTOLOAD:=$(call AutoProbe,imx_keypad)
+endef
+
+define KernelPackage/keyboard-imx/description
+ Enable support for IMX keypad port.
+endef
+
+$(eval $(call KernelPackage,keyboard-imx))