mt76: update to the latest version, fixes a SMPS handling issue
[oweals/openwrt.git] / package / kernel / linux / modules / i2c.mk
index 8fed494e4f150122af928f79f95a69704ca14ebc..e1c65d493e828daf2cd46292c576519b7a0fae4c 100644 (file)
@@ -24,10 +24,8 @@ I2C_CORE_MODULES:= \
   CONFIG_I2C:drivers/i2c/i2c-core \
   CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.12.0)),1)
-  ifeq ($(CONFIG_OF),y)
-    I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
-  endif
+ifeq ($(CONFIG_OF),y)
+  I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c@lt3.12
 endif
 
 define KernelPackage/i2c-core
@@ -142,7 +140,7 @@ I2C_MV64XXX_MODULES:=\
 define KernelPackage/i2c-mv64xxx
   $(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
   TITLE:=Orion Platform I2C interface support
-  DEPENDS:=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu +kmod-i2c-core
+  DEPENDS:=@TARGET_kirkwood||TARGET_orion +kmod-i2c-core
 endef
 
 define KernelPackage/i2c-mv64xxx/description