modules: enable crypto hardware modules
[oweals/openwrt.git] / package / kernel / linux / modules / hwmon.mk
index 971e653855d4763ccd122f7d6865b3d3f4e92989..c649847aa64a65f9610302e564c65a274d8ed2c0 100644 (file)
@@ -290,7 +290,6 @@ define KernelPackage/hwmon-pwmfan
   FILES:=$(LINUX_DIR)/drivers/hwmon/pwm-fan.ko
   AUTOLOAD:=$(call AutoLoad,60,pwm-fan)
   $(call AddDepends/hwmon,)
-  DEPENDS+=@!LINUX_3_14
 endef
 
 define KernelPackage/hwmon-pwmfan/description
@@ -305,7 +304,7 @@ define KernelPackage/hwmon-k10temp
   KCONFIG:=CONFIG_SENSORS_K10TEMP
   FILES:=$(LINUX_DIR)/drivers/hwmon/k10temp.ko
   AUTOLOAD:=$(call AutoLoad,60,k10temp)
-  $(call AddDepends/hwmon,@PCI_SUPPORT @(x86||x86_64))
+  $(call AddDepends/hwmon,@PCI_SUPPORT @TARGET_x86)
 endef
 
 define KernelPackage/hwmon-k10temp/description