kernel: add usb-mass-storage-gadget driver package
[oweals/openwrt.git] / package / kernel / linux / modules / fs.mk
index 94d4cf2a53eebf9d2e5e0f51a8efaa0b8a9a6505..5900a4b14095e0bcfa7b811471beecd976922412 100644 (file)
@@ -90,7 +90,6 @@ define KernelPackage/fs-cifs
   AUTOLOAD:=$(call AutoLoad,30,cifs)
   $(call AddDepends/nls)
   DEPENDS+= \
-    +kmod-crypto-arc4 \
     +kmod-crypto-hmac \
     +kmod-crypto-md5 \
     +kmod-crypto-md4 \
@@ -160,6 +159,7 @@ define KernelPackage/fs-ext4
     +kmod-crypto-hash
   KCONFIG:= \
        CONFIG_EXT4_FS \
+       CONFIG_EXT4_ENCRYPTION=n \
        CONFIG_JBD2
   FILES:= \
        $(LINUX_DIR)/fs/ext4/ext4.ko \
@@ -319,12 +319,12 @@ define KernelPackage/fs-nfs-common
   KCONFIG:= \
        CONFIG_LOCKD \
        CONFIG_SUNRPC \
-       CONFIG_GRACE_PERIOD@ge3.18
+       CONFIG_GRACE_PERIOD
   FILES:= \
        $(LINUX_DIR)/fs/lockd/lockd.ko \
        $(LINUX_DIR)/net/sunrpc/sunrpc.ko \
-       $(LINUX_DIR)/fs/nfs_common/grace.ko@ge3.18
-  AUTOLOAD:=$(call AutoLoad,30,grace@ge3.18 sunrpc lockd)
+       $(LINUX_DIR)/fs/nfs_common/grace.ko
+  AUTOLOAD:=$(call AutoLoad,30,grace sunrpc lockd)
 endef
 
 $(eval $(call KernelPackage,fs-nfs-common))