kernel: crypto: fix depends in kmod-crypto-hmac
[oweals/openwrt.git] / package / kernel / linux / modules / crypto.mk
index d530b1471a72394c071536f1d93774040a54118d..2e245e37a9db7897a88aa0716fef835020e96d87 100644 (file)
@@ -380,10 +380,9 @@ $(eval $(call KernelPackage,crypto-ecb))
 
 define KernelPackage/crypto-hmac
   TITLE:=HMAC digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-hash
+  DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
   KCONFIG:=CONFIG_CRYPTO_HMAC
   FILES:=$(LINUX_DIR)/crypto/hmac.ko
-  DEPENDS:=+kmod-crypto-manager
   AUTOLOAD:=$(call AutoLoad,09,hmac)
   $(call AddDepends/crypto)
 endef