kernel: crypto: fix depends in kmod-crypto-hmac
[oweals/openwrt.git] / package / kernel / linux / modules / crypto.mk
index 7324d1a87747ceae3926e61834b5d76714f5a090..2e245e37a9db7897a88aa0716fef835020e96d87 100644 (file)
@@ -66,6 +66,7 @@ define KernelPackage/crypto-manager
        CONFIG_CRYPTO_MANAGER \
        CONFIG_CRYPTO_MANAGER2
   FILES:=$(LINUX_DIR)/crypto/cryptomgr.ko
+  AUTOLOAD:=$(call AutoLoad,09,cryptomgr,1)
   $(call AddDepends/crypto)
 endef
 
@@ -379,10 +380,9 @@ $(eval $(call KernelPackage,crypto-ecb))
 
 define KernelPackage/crypto-hmac
   TITLE:=HMAC digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-hash
+  DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
   KCONFIG:=CONFIG_CRYPTO_HMAC
   FILES:=$(LINUX_DIR)/crypto/hmac.ko
-  DEPENDS:=+kmod-crypto-manager
   AUTOLOAD:=$(call AutoLoad,09,hmac)
   $(call AddDepends/crypto)
 endef