kernel: can: Add missing regmap dependency for kernel 4.4
[oweals/openwrt.git] / package / kernel / linux / modules / can.mk
index f9490b40d450115ed187ced519c85f2ba40de695..5529fe02e0cd9f17adfd82c5f2da0b652664d892 100644 (file)
@@ -26,6 +26,7 @@ define KernelPackage/can
        CONFIG_CAN_MSCAN=n \
        CONFIG_CAN_SJA1000=n \
        CONFIG_CAN_SOFTING=n \
+       CONFIG_CAN_XILINXCAN=n \
        CONFIG_NET_EMATCH_CANID=n \
        CONFIG_CAN_DEBUG_DEVICES=n
   FILES:=$(LINUX_DIR)/drivers/net/can/can-dev.ko \
@@ -240,7 +241,7 @@ $(eval $(call KernelPackage,can-c-can))
 define KernelPackage/can-c-can-platform
   TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
   KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
-  DEPENDS:=kmod-can-c-can +LINUX_4_1:kmod-regmap
+  DEPENDS:=kmod-can-c-can +!LINUX_3_18:kmod-regmap
   FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
   AUTOLOAD:=$(call AutoProbe,c_can_platform)
   $(call AddDepends/can)