kernel: mark kmod-usb-bcma/ssb as hidden, they are only selected from ohci/ehci
[oweals/openwrt.git] / package / kernel / linux / modules / 001-depends.mk
index d0ad083662d2b02b620fc03dc149cd1c1facd25b..806c3dcfd5da6d4b5b396fbabd35839ceb93762e 100644 (file)
@@ -5,19 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define AddDepends/crc16
-  DEPENDS+= +kmod-lib-crc16 $(1)
-endef
-
-define AddDepends/hid
-  DEPENDS+= +kmod-hid $(1)
-endef
-
-define AddDepends/input
-  DEPENDS+= +kmod-input-core $(1)
-endef
-
-
 define AddDepends/nls
   DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
@@ -25,8 +12,3 @@ endef
 define AddDepends/rfkill
   DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
 endef
-
-
-define AddDepends/rtc
-  DEPENDS+= @RTC_SUPPORT $(1)
-endef