mac80211: Make wlcore platform-independent
[oweals/openwrt.git] / package / kernel / ar7-atm / Makefile
index 59454fa3677ee7b0bcdb403fd161b1112156dbfb..12ea031bbb17a63ead4fea343cecef490d27a539 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -34,11 +34,13 @@ endif
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.bz2
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 
+PKG_FLAGS:=nonshared
+
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/sangam-atm/Default
   SUBMENU:=Network Devices
-  DEPENDS:=@TARGET_ar7_generic +kmod-atm @!LINUX_4_1
+  DEPENDS:=@TARGET_ar7_generic +kmod-atm
   TITLE:=AR7 ADSL driver
   FILES:=$(PKG_BUILD_DIR)/tiatm.ko
   AUTOLOAD:=$(call AutoLoad,50,tiatm)