gdb: bump to 8.3.1
[oweals/openwrt.git] / package / devel / gdb / Makefile
index ffbc9199b11e98447b03e883f458ff6fe9e5fb24..efaa46dccd4fd8a9c431c23192a88daad0bfbbc2 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=7.12.1
-PKG_RELEASE:=2
+PKG_VERSION:=8.3.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=4607680b973d3ec92c30ad029f1b7dbde3876869e6b3a117d8a7e90081113186
+PKG_HASH:=1e55b4d7cdca7b34be12f4ceae651623aa73b2fd640152313f9f66a7149757c4
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 PKG_LICENSE:=GPL-3.0+
+PKG_CPE_ID:=cpe:/a:gnu:gdb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -55,11 +56,17 @@ CONFIGURE_ARGS+= \
        --with-system-readline \
        --without-expat \
        --without-lzma \
-       --disable-werror
+       --disable-sim \
+       --disable-werror \
+       --disable-source-highlight
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
+TARGET_LDFLAGS+= \
+       -static-libstdc++ \
+       -Wl,--gc-sections
+
 define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \