gdb: bump to 8.3.1
[oweals/openwrt.git] / package / devel / gdb / Makefile
index caa13906dabbc9b1297bb2bfafbf9dfa0530d63a..efaa46dccd4fd8a9c431c23192a88daad0bfbbc2 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=8.0.1
+PKG_VERSION:=8.3.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=3dbd5f93e36ba2815ad0efab030dcd0c7b211d7b353a40a53f4c02d7d56295e3
+PKG_HASH:=1e55b4d7cdca7b34be12f4ceae651623aa73b2fd640152313f9f66a7149757c4
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 PKG_LICENSE:=GPL-3.0+
+PKG_CPE_ID:=cpe:/a:gnu:gdb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -56,7 +57,8 @@ CONFIGURE_ARGS+= \
        --without-expat \
        --without-lzma \
        --disable-sim \
-       --disable-werror
+       --disable-werror \
+       --disable-source-highlight
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"