upgrade to uci 0.4.6 - fixes a parser glitch
[oweals/openwrt.git] / package / aodv-uu / Makefile
index b670e1cca2b123bfd8b55f90bf042925d3ca78af..9f55194e1fcae20649ed7594328f82c010ce3cd9 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,33 +21,40 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/aodv-uu/Default
   TITLE:=Ad-hoc On-demand Distance Vector Routing
-  DESCRIPTION:=\
-       AODV is the Ad-hoc On-demand Distance Vector routing protocol \\\
-       implementation created at Uppsala University.
+  DEPENDS:=@BROKEN
   URL:=http://core.it.uu.se/core/index.php/AODV-UU
 endef
 
+define Package/aodv-uu/Default/description
+ AODV is the Ad-hoc On-demand Distance Vector routing protocol
+ implementation created at Uppsala University.
+endef
+
 define Package/aodv-uu
-  $(call Package/aodv-uu/Default)
+$(call Package/aodv-uu/Default)
   SECTION:=net
   CATEGORY:=Network
   TITLE+= (daemon)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the AODV userland daemon.
+endef
+
+define Package/aodv-uu/description
+$(call Package/aodv-uu/Default/description)
+ This package contains the AODV userland daemon.
 endef
 
 define KernelPackage/aodv-uu
-  $(call Package/aodv-uu/Default)
+$(call Package/aodv-uu/Default)
   TITLE+= (kernel module)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the AODV kernel module.
   FILES:=$(PKG_BUILD_DIR)/lnx/kaodv.$(LINUX_KMOD_SUFFIX)
   SUBMENU:=Network Support
   AUTOLOAD:=$(call AutoLoad,80,$(shell cat ./files/aodv-uu.modules))
 endef
 
+define KernelPackage/aodv-uu/description
+$(call Package/aodv-uu/Default/description)
+ This package contains the AODV kernel module.
+endef
+
 ifeq ($(CONFIG_LINUX_2_6),y)
   define Build/Compile/linux26
        $(MAKE) -C $(LINUX_DIR) \