fix everything I broke with the previous patches
[librecmc/librecmc.git] / openwrt / toolchain / uClibc / Makefile
index 1499573cedcb8c5997c72cea1ea2760328fb84d8..a99c734b92fc3448db04110164c8438ed21a539d 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
@@ -49,7 +55,7 @@ endif
        mkdir -p $(TOOL_BUILD_DIR)/uClibc_dev/usr/include
        mkdir -p $(TOOL_BUILD_DIR)/uClibc_dev/usr/lib
        mkdir -p $(TOOL_BUILD_DIR)/uClibc_dev/lib
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       PATH=$(TARGET_PATH) $(MAKE) -C $(PKG_BUILD_DIR) \
                PREFIX=$(TOOL_BUILD_DIR)/uClibc_dev/ \
                DEVEL_PREFIX=/usr/ \
                RUNTIME_PREFIX=$(TOOL_BUILD_DIR)/uClibc_dev/ \
@@ -62,7 +68,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       PATH=$(TARGET_PATH) $(MAKE) -C $(PKG_BUILD_DIR) \
                PREFIX= \
                DEVEL_PREFIX=/ \
                RUNTIME_PREFIX=/ \