Added support for ATM (needed by ueagle-atm), USB ATM, and VISOR USB serial controlle...
[oweals/openwrt.git] / openwrt / target / linux / linux-2.6 / Makefile
index 30b2d79814394f32219db77544a5649166f64016..d64d7cca06168586a516dfdf0a76fa0ef37332b2 100644 (file)
@@ -5,8 +5,8 @@ include $(TOPDIR)/rules.mk
 include ../rules.mk
 
 KERNEL:=2.6
-LINUX_VERSION:=2.6.15-rc5
-LINUX_KERNEL_MD5SUM:=1b430bfd22f4094bf1bdc1a5ceb6b6a2
+LINUX_VERSION:=2.6.15-rc6
+LINUX_KERNEL_MD5SUM:=eeead0b884811411fd2df8520744b253
 LINUX_SITE=http://www.fi.kernel.org/pub/linux/kernel/v2.6/testing \
            http://www.fr.kernel.org/pub/linux/kernel/v2.6/testing \
            http://www.kernel.org/pub/linux/kernel/v2.6/testing \
@@ -366,6 +366,10 @@ $(eval $(call KMOD_template,USB_SERIAL_PL2303,usb-serial-pl2303,\
        $(MODULES_DIR)/kernel/drivers/usb/serial/pl2303.ko \
 ,CONFIG_USB_SERIAL_PL2303,kmod-usb-serial,61,pl2303))
 
+$(eval $(call KMOD_template,USB_SERIAL_VISOR,usb-serial-visor,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/visor.o \
+,CONFIG_USB_SERIAL_VISOR,kmod-usb-serial,61,visor))
+
 $(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
        $(MODULES_DIR)/kernel/drivers/scsi/scsi_mod.ko \
        $(MODULES_DIR)/kernel/drivers/scsi/sd_mod.ko \