add new image builder
[oweals/openwrt.git] / openwrt / target / linux / image / squashfs.mk
index e9a95de560da77bc053c55a1a9663f06064dc507..42ff77db6455e6643932fa8fea34d50eb8411f62 100644 (file)
@@ -10,10 +10,17 @@ squashfs-clean:
 
 $(KDIR)/root.squashfs:
        @mkdir -p $(KDIR)/root/jffs
-       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -noappend -root-owned -le
+       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le
 
-prepare: squashfs-prepare
-compile: squashfs-compile
-install: $(KDIR)/root.squashfs
+squashfs-install: $(KDIR)/root.squashfs
        $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
 
+squashfs-install-ib:
+       mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
+       cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
+       
+prepare: squashfs-prepare
+compile: squashfs-compile
+install: squashfs-install
+install-ib: squashfs-install-ib
+clean: squashfs-clean