sed-host forgotten in last commit
[oweals/openwrt.git] / openwrt / package / sed / sed.mk
index 5154c1f795d5f2429d4da1cb7418183e65cf7e4b..e56df9a30804bac00e2f8f31f237f5fe5c177708 100644 (file)
@@ -69,10 +69,9 @@ use-sed-host-binary:
 host-sed: $(HOST_SED_TARGET)
 
 host-sed-clean:
-       $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SED_DIR1) uninstall
        -$(MAKE) -C $(SED_DIR1) clean
 
-host-sed-dirclean:
+host-sed-toolclean:
        rm -rf $(SED_DIR1)
 
 
@@ -127,10 +126,11 @@ sed-target_binary: $(SED_DIR2)/$(SED_BINARY)
 sed: uclibc sed-target_binary
 
 sed-clean:
-       $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(SED_DIR2) uninstall
        -$(MAKE) -C $(SED_DIR2) clean
 
 sed-dirclean:
        rm -rf $(SED_DIR2)
 
-
+ifeq ($(strip $(BR2_PACKAGE_SED)),y)
+TARGETS+=sed
+endif