work around a make bug in define/endef handling
[oweals/openwrt.git] / openwrt / package / rules.mk
index 0920f7bcf30e09fd94159e77dde7d1a18a5893cf..ac9b98d74c49cd08adc69d74fbc9c9f67cfffbbc 100644 (file)
@@ -1,5 +1,8 @@
-# default target
+ifneq ($(DUMP),)
+all: dumpinfo
+else
 all: compile
+endif
 
 define Build/DefaultTargets
 $(PKG_BUILD_DIR)/.prepared:
@@ -8,20 +11,32 @@ $(PKG_BUILD_DIR)/.prepared:
        $(call Build/Prepare)
        touch $$@
 
-$(PKG_BUILD_DIR)/.configured:
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        $(call Build/Configure)
        touch $$@
 
-$(PKG_BUILD_DIR)/.built:
+ifeq ($(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),.)
+$(PKG_BUILD_DIR)/.prepared: clean
+endif
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
        touch $$@
 
+package-clean:
+       $(call Build/Clean)
+       rm -f $(PKG_BUILD_DIR)/.built
+
+package-recompile:
+       rm -f $(PKG_BUILD_DIR)/.built
+
+.PHONY: package-clean package-recompile
+
 define Build/DefaultTargets
 endef
 endef
 
-
-define BuildPackage
+define Package/Default
 CONFIGFILE:=
 SECTION:=opt
 CATEGORY:=Extra packages
@@ -33,8 +48,11 @@ PKGARCH:=$(ARCH)
 PRIORITY:=optional
 TITLE:=
 DESCRIPTION:=
+endef
 
-$$(eval $$(call Package/$(1)))
+define BuildPackage
+$(eval $(call Package/Default))
+$(eval $(call Package/$(1)))
 
 ifeq ($$(TITLE),)
 $$(error Package $(1) has no TITLE)
@@ -56,43 +74,65 @@ IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
 IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
 INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-ifneq ($(BR2_PACKAGE_$(1)),)
-compile-targets: $$(IPKG_$(1))
+ifneq ($(PACKAGE_$(1)),)
+COMPILE_$(1):=1
 endif
 ifneq ($(DEVELOPER),)
-compile-targets: $$(IPKG_$(1))
+COMPILE_$(1):=1
 endif
-ifeq ($(BR2_PACKAGE_$(1)),y)
+ifeq ($(PACKAGE_$(1)),y)
 install-targets: $$(INFO_$(1))
 endif
 
+ifneq ($$(COMPILE_$(1)),)
+ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$(PKG_BUILD_DIR))
+$(PKG_BUILD_DIR)/.built: package-recompile
+endif
+
+compile-targets: $$(IPKG_$(1))
+endif
+
+
 IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
+DUMPINFO += \
+       echo "Package: $(1)"; \
+       echo "Version: $(VERSION)"; \
+       echo "Depends: $(IDEPEND_$(1))"; \
+       echo "Title: $(TITLE)"; \
+       echo "$(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+       echo; \
+       echo "$(URL)"; \
+       echo "@@";
+
+
 $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
-       echo "Version: $$(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Source: $$(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Section: $$(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Priority: $$(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Maintainer: $$(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Architecture: $$(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Description: $$(DESCRIPTION)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Depends: $(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Description: $(TITLE)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "  $(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
        for file in conffiles preinst postinst prerm postrm; do \
                [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done
 
-$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built $(PACKAGE_DIR)
+$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
+       mkdir -p $(PACKAGE_DIR)
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
 $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
 
 $(1)-clean:
-       rm -f $$(IPKG_$(1))
+       rm -f $(PACKAGE_DIR)/$(1)_*
 clean: $(1)-clean
 
 ifneq ($(__DEFAULT_TARGETS),1)
@@ -142,6 +182,15 @@ define Build/Compile
 $(call Build/Compile/Default)
 endef
 
+define Build/Clean
+       $(MAKE) clean
+endef
+
+ifneq ($(DUMP),)
+dumpinfo:
+       $(DUMPINFO)
+else
+
 source: $(DL_DIR)/$(PKG_SOURCE)
 prepare: source
        @[ -f $(PKG_BUILD_DIR)/.prepared ] || { \
@@ -165,14 +214,9 @@ install:
        @$(CMD_TRACE) "installing... "
        @$(MAKE) install-targets $(MAKE_TRACE)
 
-mostlyclean:
 rebuild:
        $(CMD_TRACE) "rebuilding... "
-       @-$(MAKE) mostlyclean 2>&1 >/dev/null
-       if [ -f $(PKG_BUILD_DIR)/.built ]; then \
-               $(MAKE) clean $(MAKE_TRACE); \
-       fi
-       $(MAKE) compile $(MAKE_TRACE)
+       $(MAKE) package-clean compile $(MAKE_TRACE)
 
 $(PACKAGE_DIR):
        mkdir -p $@
@@ -182,5 +226,6 @@ clean:
        @$(CMD_TRACE) "cleaning... " 
        @$(MAKE) clean-targets $(MAKE_TRACE)
        rm -rf $(PKG_BUILD_DIR)
+endif
 
-.PHONY: all source prepare compile install clean
+.PHONY: all source prepare compile install clean rebuild dumpinfo compile-targets install-targets clean-targets