normalize Makefiles.
[oweals/openwrt.git] / openwrt / package / rules.mk
index 9b551728b3a97e7ad84d84763083a6b9a6daf0f7..40e07f839fe2a72a821c60f1ced2b4a43ff96784 100644 (file)
@@ -6,12 +6,16 @@ endif
 
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . | tee /tmp/xy1),.)
-      $(PKG_BUILD_DIR)/.prepared: package-clean
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.prepared: package-clean
+      endif
     endif
 
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/xy2),$(IPKG_$(1)))
-      $(PKG_BUILD_DIR)/.built: package-rebuild
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.built: package-rebuild
+      endif
     endif
   endif
 
@@ -28,17 +32,22 @@ define Build/DefaultTargets
   $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
        touch $$@
-    
-  $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
+
+  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
        $(call Build/InstallDev)
        touch $$@
-    
+       
+  ifdef Build/InstallDev
+    compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+  endif
+
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
+       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
-       @-rm $(PKG_BUILD_DIR)/.built
+       @-rm -f $(PKG_BUILD_DIR)/.built
 
   define Build/DefaultTargets
   endef
@@ -49,10 +58,17 @@ define Package/Default
   SECTION:=opt
   CATEGORY:=Extra packages
   DEPENDS:=
-  NEEDS:=
   MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
   SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
-  VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+  ifneq ($(PKG_VERSION),)
+    ifneq ($(PKG_RELEASE),)
+      VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+    else
+      VERSION:=$(PKG_VERSION)
+    endif
+  else
+    VERSION:=$(PKG_RELEASE)
+  endif
   PKGARCH:=$(ARCH)
   PRIORITY:=optional
   DEFAULT:=
@@ -61,6 +77,12 @@ define Package/Default
   DESCRIPTION:=
 endef
 
+define BuildIPKGVariable
+pkg_$(subst .,_,$(subst -,_,$(1)))_$(2) = $$(Package/$(1)/$(2))
+export pkg_$(subst .,_,$(subst -,_,$(1))_$(2))
+$(1)_COMMANDS += if [ -n "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" ]; then echo "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" > $(2); fi;
+endef
+
 define BuildPackage
   $(eval $(call Package/Default))
   $(eval $(call Package/$(1)))
@@ -92,7 +114,6 @@ define BuildPackage
   endif
 
   IDEPEND_$(1):=$$(strip $$(DEPENDS))
-  INEED_$(1):=$$(strip $$(NEEDS))
 
   DUMPINFO += \
        echo "Package: $(1)"; 
@@ -110,7 +131,7 @@ define BuildPackage
   DUMPINFO += \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
-       echo "Needs: $$(INEED_$(1))"; \
+       echo "Build-Depends: $(PKG_BUILDDEP)"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
@@ -130,12 +151,22 @@ define BuildPackage
        echo "@@";
   endif
 
+  $(eval $(call BuildIPKGVariable,$(1),conffiles))
+  $(eval $(call BuildIPKGVariable,$(1),preinst))
+  $(eval $(call BuildIPKGVariable,$(1),postinst))
+  $(eval $(call BuildIPKGVariable,$(1),prerm))
+  $(eval $(call BuildIPKGVariable,$(1),postrm))
   $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
-       #FIXME: there should be a better way to do it
-       D="$$(IDEPEND_$(1))"; D="$$$${D}$$$${D:+, }$$(INEED_$(1))"; echo "Depends: $$$${D}" >> $$(IDIR_$(1))/CONTROL/control
+       ( \
+               DEPENDS=; \
+               for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
+                       DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
+               done; \
+               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+       )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
@@ -143,21 +174,22 @@ define BuildPackage
        echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
-       for file in conffiles preinst postinst prerm postrm; do \
-               [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
-       done
+       (cd $$(IDIR_$(1))/CONTROL; \
+               $($(1)_COMMANDS) \
+       )
 
   $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
+       -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
+       -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
   $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
 
-  compile-targets: $(PKG_BUILD_DIR)/.dev-installed
-
   $(1)-clean:
        rm -f $(PACKAGE_DIR)/$(1)_*
 
@@ -190,8 +222,9 @@ define Build/Prepare
 endef
 
 define Build/Configure/Default
-       @(cd $(PKG_BUILD_DIR); \
+       @(cd $(PKG_BUILD_DIR)/$(3); \
        [ -x configure ] && \
+               $(2) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -224,12 +257,11 @@ endef
 
 define Build/Compile/Default
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                CC=$(TARGET_CC) \
                CROSS="$(TARGET_CROSS)" \
-               PREFIX="$$(IDIR_$(1))" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
                ARCH="$(ARCH)" \
-               DESTDIR="$$(IDIR_$(1))" \
                $(1);
 endef
 
@@ -237,16 +269,6 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
-define Build/InstallDev
-endef
-
-define Build/Clean
-       $(MAKE) clean
-endef
-
-define Build/UninstallDev
-endef
-
 ifneq ($(DUMP),)
   dumpinfo: FORCE
        @$(DUMPINFO)
@@ -268,5 +290,6 @@ else
   clean-targets:
   clean: FORCE
        @$(MAKE) clean-targets
+       $(call Build/Clean)
        rm -rf $(PKG_BUILD_DIR)
 endif