.pkginfo cleanup #2
[librecmc/librecmc.git] / openwrt / package / base-files / Makefile
index 226782bb92dec0b37f9c4610dc6e8c766d64c7cd..f81c681c2649e2c86dee0601a559bed880a21045 100644 (file)
@@ -1,7 +1,7 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(TOPDIR)/package/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
 PKG_RELEASE:=8
@@ -12,38 +12,84 @@ ifeq ($(REV),)
 REV:=0
 endif
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 ifneq ($(DUMP),1)
 TARGET:=-$(BOARD)-$(KERNEL)
 UCLIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version}
 LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
+else
+UCLIBC_VERSION:=<UCLIBC_VERSION>
+LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
-CONFIG_PACKAGE_base-files$(TARGET):=CONFIG_PACKAGE_base-files
+CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
 
 define Package/base-files$(TARGET)
- SECTION:=base
- CATEGORY:=Base system
- DEFAULT:=y
- TITLE:=OpenWrt system scripts
- DESCRIPTION:=Base filesystem for OpenWrt
+SECTION:=base
+CATEGORY:=Base system
+DEFAULT:=y
+TITLE:=OpenWrt system scripts
+DESCRIPTION:=Base filesystem for OpenWrt
+VERSION:=$(PKG_RELEASE)
+endef
+
+define -ar7-2.4/conffiles
+/etc/config/network
+endef
+
+define -aruba-2.6/conffiles
+/etc/config/network
+endef
+
+define -au1000-2.6/conffiles
+/etc/config/network
+endef
+
+define -rb532-2.6/conffiles
+/etc/config/network
+endef
+
+define -sibyte-2.6/conffiles
+/etc/config/network
+endef
+
+define -x86-2.6/conffiles
+/etc/config/network
+endef
+
+define -xscale-2.6/conffiles
+/etc/config/network
+endef
+
+
+define Package/base-files$(TARGET)/conffiles
+/etc/banner
+/etc/hosts
+/etc/inittab
+/etc/group
+/etc/passwd
+/etc/profile
+/etc/shells
+/etc/ipkg.conf
+/etc/sysctl.conf
+$(call $(TARGET)/conffiles)
 endef
 
 define Package/libgcc
- SECTION:=libs
- CATEGORY:=Libraries
- DEFAULT:=m, y if GCC_VERSION_4_0_2 || GCC_VERSION_4_0_3 || GCC_VERSION_4_1_0
- TITLE:=GCC support library
- VERSION:=$(LIBGCC_VERSION)-$(PKG_RELEASE)
- DESCRIPTION:=$(TITLE)
+SECTION:=libs
+CATEGORY:=Libraries
+DEFAULT:=y
+TITLE:=GCC support library
+VERSION:=$(LIBGCC_VERSION)-$(PKG_RELEASE)
+DESCRIPTION:=$(TITLE)
 endef
 
 define Package/uclibc
- $(call Package/base-files$(TARGET))
- VERSION:=$(UCLIBC_VERSION)-$(PKG_RELEASE)
- TITLE:=C library
- DESCRIPTION:=C library for embedded systems
+$(call Package/base-files$(TARGET))
+VERSION:=$(UCLIBC_VERSION)-$(PKG_RELEASE)
+TITLE:=C library
+DESCRIPTION:=C library for embedded systems
 endef
 
 define Build/Prepare
@@ -75,7 +121,7 @@ endef
 
 define Package/base-files$(TARGET)/install
 $(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
-       $(CP) ./default/* $(1)
+       $(CP) ./default/* $(1)/
        if [ -d $(BOARD)-$(KERNEL) ]; then \
                $(CP) $(BOARD)-$(KERNEL)/* $(1)/; \
        fi