fix a few directories missed in [4176]'s source -> download
[oweals/openwrt.git] / openwrt / include / verbose.mk
index 58a20a217841e8d5ceb8dc10741a8a10717b222c..7d9b3979bffcb171ff025375d4c1324a6ebca5ab 100644 (file)
@@ -6,10 +6,13 @@
 #
 # $Id:$
 
-NO_TRACE_MAKE:=$(MAKE) V=99
+export NO_TRACE_MAKE:=$(MAKE) V=99
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=$(V)
+  KBUILD_VERBOSE=0
+  ifeq ("$(origin V)", "command line")
+    KBUILD_VERBOSE=$(V)
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -29,6 +32,4 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
-else
-   NO_TRACE_MAKE:=$(MAKE)
 endif