correct [4397]
[librecmc/librecmc.git] / openwrt / include / package.mk
index 3dc944dbfa0a21774866fd1e0027c91f5ae7d18f..b4b6538b6b32b90e0e9ec99096740b9c9d3a0195 100644 (file)
@@ -19,7 +19,7 @@ define Build/DefaultTargets
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
-      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/check_$(1)),$(IPKG_$(1)))
         $(PKG_BUILD_DIR)/.built: package-rebuild
       endif
     endif
@@ -121,7 +121,7 @@ define BuildPackage
       install-targets: $$(INFO_$(1))
     endif
 
-    ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
+    ifneq ($(CONFIG_PACKAGE_$(1)),)
       compile-targets: $$(IPKG_$(1))
     endif
   endif