Fixes for no-static-engine and Windows builds.
[oweals/openssl.git] / openssl.spec
index 38426e3b4f831a064f6714b6c0ca52154556913f..bb182ba1d354aec65a988f17e71ac3a71406dcfc 100644 (file)
@@ -1,15 +1,16 @@
+%define _unpackaged_files_terminate_build 0
 %define libmaj 0
 %define libmin 9
 %define librel 8
-#%define librev a
-Release: 2
+%define librev za
+Release: 1
 
 %define openssldir /var/ssl
 
 Summary: Secure Sockets Layer and cryptography libraries and tools
 Name: openssl
-Version: %{libmaj}.%{libmin}.%{librel}
-#Version: %{libmaj}.%{libmin}.%{librel}%{librev}
+#Version: %{libmaj}.%{libmin}.%{librel}
+Version: %{libmaj}.%{libmin}.%{librel}%{librev}
 Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
 Copyright: Freely distributable
 Group: System Environment/Libraries
@@ -96,6 +97,9 @@ perl util/perlpath.pl /usr/bin/perl
 %ifarch alpha
 ./Configure %{CONFIG_FLAGS} linux-alpha shared
 %endif
+%ifarch x86_64
+./Configure %{CONFIG_FLAGS} linux-x86_64 shared
+%endif
 LD_LIBRARY_PATH=`pwd` make
 LD_LIBRARY_PATH=`pwd` make rehash
 LD_LIBRARY_PATH=`pwd` make test