bcm53xx: use uncompressed zImages
[oweals/openwrt.git] / include / version.mk
index d8da358d696912bad879d48edf9b57d652fe4c91..88d6245fcd5bc73c006a44a882de2e86105f0633 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE Project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,6 +9,8 @@
 # Substituted by SDK, do not remove
 # REVISION:=x
 
+RELEASE:=Reboot
+
 PKG_CONFIG_DEPENDS += \
        CONFIG_VERSION_NUMBER \
        CONFIG_VERSION_NICK \
@@ -21,6 +24,8 @@ PKG_CONFIG_DEPENDS += \
 qstrip_escape=$(subst ','\'',$(call qstrip,$(1)))
 #'
 
+sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
+
 VERSION_NUMBER:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
 VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),$(REVISION))
 
@@ -31,10 +36,11 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots/trunk/%S/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),LEDE)
+VERSION_DIST_SANITIZED:=$(call sanitize,$(VERSION_DIST))
 
 VERSION_MANUFACTURER:=$(call qstrip_escape,$(CONFIG_VERSION_MANUFACTURER))
 VERSION_MANUFACTURER:=$(if $(VERSION_MANUFACTURER),$(VERSION_MANUFACTURER),LEDE)
@@ -84,6 +90,7 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
        -e 's,%R,$(REVISION),g' \
        -e 's,%T,$(BOARD),g' \
        -e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
+       -e 's,%A,$(ARCH_PACKAGES),g' \
        -e 's,%t,$(VERSION_TAINTS),g' \
        -e 's,%M,$(VERSION_MANUFACTURER),g' \
        -e 's,%m,$(VERSION_MANUFACTURER_URL),g' \