speed up metadata scanning a lot by avoiding unnecessary shell commands and make...
[oweals/openwrt.git] / include / kernel-version.mk
index c8503863fedb64938dcdc514c553e9e37e9c30e6..003fc085b38cbb9ba5588be63128e0fbec986f7f 100644 (file)
@@ -28,16 +28,18 @@ endif
 ifeq ($(LINUX_VERSION),2.6.26.8)
   LINUX_KERNEL_MD5SUM:=05dd0d4f8f110b4219ae6ec7a36c046d
 endif
-ifeq ($(LINUX_VERSION),2.6.27.13)
-  LINUX_KERNEL_MD5SUM:=e1035cd771ef2aed59396d8cab543a0c 
+ifeq ($(LINUX_VERSION),2.6.27.19)
+  LINUX_KERNEL_MD5SUM:=182b23174febe7cc8106dd394f368dee
 endif
-ifeq ($(LINUX_VERSION),2.6.28)
-  LINUX_KERNEL_MD5SUM:=d351e44709c9810b85e29b877f50968a
+ifeq ($(LINUX_VERSION),2.6.28.7)
+  LINUX_KERNEL_MD5SUM:=72d7d509c1f997e6d043bc9c683d89f1
 endif
 
 # disable the md5sum check for unknown kernel versions
 LINUX_KERNEL_MD5SUM?=x
 
-KERNEL?=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
-KERNEL_PATCHVER=$(shell echo '$(LINUX_VERSION)' | cut -d. -f1,2,3 | cut -d- -f1)
+split_version=$(subst ., ,$(1))
+merge_version=$(subst $(space),.,$(1))
+KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(LINUX_VERSION))))
+KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(LINUX_VERSION))))