brcm63xx: Add support for ADB P.DG A4001N
[oweals/openwrt.git] / include / image.mk
index 71971e21ca50910e5688114713a0fc5fe3efe508..9f583ca7adf703c06949e0d6adc57ed1665472c2 100644 (file)
@@ -14,6 +14,7 @@ include $(INCLUDE_DIR)/host.mk
 override MAKEFLAGS=
 override MAKE:=$(SUBMAKE)
 KDIR=$(KERNEL_BUILD_DIR)
+DTS_DIR:=$(LINUX_DIR)/arch/$(ARCH)/boot/dts/
 
 IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
 
@@ -142,15 +143,14 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
    endef
 # $(1) board name
-# $(2) ubinize-image options (e.g. --no-kernel and/or --uboot-env)
+# $(2) ubinize-image options (e.g. --uboot-env and/or --kernel kernelimage)
 # $(3) rootfstype (e.g. squashfs or ubifs)
-# $(4) kernel image file
-# $(5) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
+# $(4) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
    define Image/Build/UbinizeImage
        sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
-               "$(KDIR)/root.$(3)" "$(4)" \
+               "$(KDIR)/root.$(3)" \
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
-               $(5)
+               $(4)
    endef
 
 endif