build: introduce extra targets that contain only proper dependencies
[oweals/openwrt.git] / include / host-build.mk
index 0bd386781dfbd6d9144c59a12a7708d1e389ab42..c38f8cfeb7eb95d2ff6957566ebfb87c5eeda236 100644 (file)
@@ -175,10 +175,10 @@ ifndef DUMP
     )
   endif
 
-  host-prepare: $(HOST_STAMP_PREPARED)
-  host-configure: $(HOST_STAMP_CONFIGURED)
-  host-compile: $(HOST_STAMP_BUILT) $(if $(STAMP_BUILT),$(HOST_STAMP_INSTALLED))
-  host-install: $(HOST_STAMP_INSTALLED)
+  .host-prepare: $(HOST_STAMP_PREPARED)
+  .host-configure: $(HOST_STAMP_CONFIGURED)
+  .host-compile: $(HOST_STAMP_BUILT) $(if $(STAMP_BUILT),$(HOST_STAMP_INSTALLED))
+  .host-install: $(HOST_STAMP_INSTALLED)
   host-clean: FORCE
        $(call Host/Clean)
        $(call Host/Uninstall)