more whitespace fixes
[oweals/busybox.git] / examples / busybox.spec
index ee92610d0d2db72319f953ca0e58126e09b75645..494eed94135d3a4f112d0acfce727f08c8e0dffd 100644 (file)
@@ -1,13 +1,21 @@
-Name: busybox
-Version: 0.46
-Release: 1
+%define name   busybox
+%define epoch   0
+%define version        0.61.pre
+%define release        %(date -I | sed -e 's/-/_/g')
+%define serial  1
+
+Name:   %{name}
+#Epoch:   %{epoch}
+Version: %{version}
+Release: %{release}
+Serial:         %{serial}
+Copyright: GPL
 Group: System/Utilities
 Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
-Copyright: GPL
-Packager : Erik Andersen <andersen@lineo.com>
-Conflicts: fileutils grep shellutils
-Buildroot: /tmp/%{Name}-%{Version}
-Source: %{Name}-%{Version}.tar.gz
+URL:    http://busybox.net/
+Source:         ftp://busybox.net/busybox/%{name}-%{version}.tar.gz
+Buildroot: /var/tmp/%{name}-%{version}
+Packager : Erik Andersen <andersen@codepoet.org>
 
 %Description
 BusyBox combines tiny versions of many common UNIX utilities into a single
@@ -19,18 +27,18 @@ their full featured GNU cousins; however, the options that are provided behave
 very much like their GNU counterparts.
 
 %Prep
-%setup -q -n %{Name}-%{Version}
+%setup -q -n %{name}-%{version}
 
 %Build
 make
 
 %Install
 rm -rf $RPM_BUILD_ROOT
-make PREFIX=$RPM_BUILD_ROOT install
+make CONFIG_PREFIX=$RPM_BUILD_ROOT install
 
 %Clean
 rm -rf $RPM_BUILD_ROOT
 
-%Files 
+%Files
 %defattr(-,root,root)
 /