sync with dash_0.5.3-1
[oweals/busybox.git] / examples / busybox.spec
index 0cc15d43533298eabebb23e43d8598725d2e4934..3986436c164f723aba377cfd5b01d8099ecfdd9c 100644 (file)
@@ -1,43 +1,44 @@
-Name: busybox
-Version: 0.32
-Release: 1
+%define name   busybox
+%define epoch   0
+%define version        0.61.pre
+%define release        %(date -I | sed -e 's/-/_/g')
+%define serial  1
+
+Name:   %{name}
+#Epoch:   %{epoch}
+Version: %{version}
+Release: %{release}
+Serial:         %{serial}
+Copyright: GPL
 Group: System/Utilities
 Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
-Copyright: GPL
-Packager : Erik Andersen <andersen@lineo.com>
-Conflicts: fileutils grep shellutils
-Buildroot: /tmp/%{Name}-%{Version}
-Source: busybox-0.32.tar.gz
+URL:    http://busybox.net/
+Source:         ftp://busybox.net/busybox/%{name}-%{version}.tar.gz
+Buildroot: /var/tmp/%{name}-%{version}
+Packager : Erik Andersen <andersen@codepoet.org>
 
 %Description
-BusyBox is a suite of "tiny" Unix utilities in a multi-call binary. It
-provides a pretty complete POSIX environment in a very small package.
-Just add a kernel, "ash" (Keith Almquists tiny Bourne shell clone), and
-an editor such as "elvis-tiny" or "ae", and you have a full system. This
-is makes an excellent environment for a "rescue" disk or any small or
-embedded system.
+BusyBox combines tiny versions of many common UNIX utilities into a single
+small executable. It provides minimalist replacements for most of the utilities
+you usually find in fileutils, shellutils, findutils, textutils, grep, gzip,
+tar, etc.  BusyBox provides a fairly complete POSIX environment for any small
+or emdedded system.  The utilities in BusyBox generally have fewer options then
+their full featured GNU cousins; however, the options that are provided behave
+very much like their GNU counterparts.
 
 %Prep
-%setup -q -n busybox
+%setup -q -n %{name}-%{version}
 
 %Build
 make
 
 %Install
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/bin
-h=`cat busybox.links`
-
-for i in $h ; do
-       mkdir -p $RPM_BUILD_ROOT/`echo $i | sed -e 's/\(^.*\/\)\(.*\)/\1/g' `
-       (cd $RPM_BUILD_ROOT/bin ; ln -s busybox `echo $i | sed -e 's/\(^.*\/\)\(.*\)/\2/g' ` ); 
-done 
-rm -f $RPM_BUILD_ROOT/bin/busybox
-install -m 755 busybox $RPM_BUILD_ROOT/bin/busybox
+make PREFIX=$RPM_BUILD_ROOT install
 
 %Clean
 rm -rf $RPM_BUILD_ROOT
 
-%Files 
+%Files
 %defattr(-,root,root)
 /