A missing securetty file is not an error.
[oweals/busybox.git] / debian / rules
index 5271b97fd22e067ce329abf92180d005482bf2f5..a84153693ad5bc87ed51e44386b76f3c246d2e97 100755 (executable)
@@ -28,8 +28,8 @@ debian/build-stamp-busybox:
        mkdir -p $(bbbd)
        cp Makefile $(bbbd)
        cp debian/Config.h-deb $(bbbd)/Config.h
-       -(cd $(bbbd); $(MAKE) "BB_SRC_DIR=../../" applet_source_list)
-       (cd $(bbbd); $(MAKE) USE_SYSTEM_PWD_GRP=false "BB_SRC_DIR=../../")
+       -(cd $(bbbd); $(MAKE) "CONFIG_SRC_DIR=../../" applet_source_list)
+       (cd $(bbbd); $(MAKE) USE_SYSTEM_PWD_GRP=false "CONFIG_SRC_DIR=../../")
        touch debian/build-stamp-busybox
 
 install: build
@@ -39,11 +39,11 @@ install: build
        dh_installdirs
        # Do not run 'make install', since we do not want all the symlinks. 
        # This just installes the busybox binary...
-       #(cd $(bbbd); $(MAKE) "BB_SRC_DIR=../../" "PREFIX=../../$(bb)" install)
+       #(cd $(bbbd); $(MAKE) "CONFIG_SRC_DIR=../../" "PREFIX=../../$(bb)" install)
        mkdir -p $(bb)/bin/
        cp $(bbbd)/busybox $(bb)/bin/busybox
-       mkdir -p $(bb)/usr/share/doc/busybox/busybox.lineo.com
-       cp $(bbbd)/docs/busybox.lineo.com/BusyBox.html $(bb)/usr/share/doc/busybox/busybox.lineo.com/
+       mkdir -p $(bb)/usr/share/doc/busybox/busybox.net
+       cp $(bbbd)/docs/busybox.net/BusyBox.html $(bb)/usr/share/doc/busybox/busybox.net/
        mkdir -p $(bb)/usr/share/man/man1
        cp $(bbbd)/docs/BusyBox.1 $(bb)/usr/share/man/man1/busybox.1
 
@@ -54,7 +54,7 @@ debian/build-stamp-busybox-static:
        mkdir -p $(bbsbd)
        cp Makefile $(bbsbd)
        cp debian/Config.h-static $(bbsbd)/Config.h
-       (cd $(bbsbd); $(MAKE) DOSTATIC=true USE_SYSTEM_PWD_GRP=false "BB_SRC_DIR=../../")
+       (cd $(bbsbd); $(MAKE) DOSTATIC=true USE_SYSTEM_PWD_GRP=false "CONFIG_SRC_DIR=../../")
        touch debian/build-stamp-busybox-static
 
 install-static: build
@@ -64,11 +64,11 @@ install-static: build
        dh_installdirs
        # Do not run 'make install', since we do not want all the symlinks. 
        # This just installes the busybox binary...
-       #(cd $(bbsbd); $(MAKE) "BB_SRC_DIR=../../" "PREFIX=../../$(bbs)" install)
+       #(cd $(bbsbd); $(MAKE) "CONFIG_SRC_DIR=../../" "PREFIX=../../$(bbs)" install)
        mkdir -p $(bbs)/bin/
        cp $(bbsbd)/busybox $(bbs)/bin/busybox
-       mkdir -p $(bbs)/usr/share/doc/busybox-static/busybox.lineo.com
-       cp $(bbsbd)/docs/busybox.lineo.com/BusyBox.html $(bbs)/usr/share/doc/busybox-static/busybox.lineo.com/
+       mkdir -p $(bbs)/usr/share/doc/busybox-static/busybox.net
+       cp $(bbsbd)/docs/busybox.net/BusyBox.html $(bbs)/usr/share/doc/busybox-static/busybox.net/
        mkdir -p $(bbs)/usr/share/man/man1/
        cp $(bbsbd)/docs/BusyBox.1 $(bbs)/usr/share/man/man1/busybox.1
 
@@ -84,10 +84,9 @@ do_static: half_clean build-static install-static
 
 # Now for the .udeb stuff
 PACKAGE=busybox-udeb
-VERSION=$(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2)
+VERSION=$(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2 | sed -e s/[0-9]://g)
 ARCH=$(shell dpkg --print-architecture)
 FILENAME=$(PACKAGE)_$(VERSION)_$(ARCH).udeb
-PRIORITY=$(shell grep ^Priority: debian/control | cut -d ' ' -f 2)
 
 build-udeb: debian/build-stamp-busybox-udeb
 debian/build-stamp-busybox-udeb:
@@ -95,7 +94,7 @@ debian/build-stamp-busybox-udeb:
        mkdir -p $(bbubd)
        cp Makefile $(bbubd)
        cp debian/Config.h-udeb $(bbubd)/Config.h
-       (cd $(bbubd); $(MAKE) USE_SYSTEM_PWD_GRP=false "BB_SRC_DIR=../../")
+       (cd $(bbubd); $(MAKE) USE_SYSTEM_PWD_GRP=false "CONFIG_SRC_DIR=../../")
        touch debian/build-stamp-busybox-udeb
 
 install-udeb: build
@@ -103,7 +102,7 @@ install-udeb: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       (cd $(bbubd); $(MAKE) "BB_SRC_DIR=../../" "PREFIX=../../$(bbu)" install)
+       (cd $(bbubd); $(MAKE) "CONFIG_SRC_DIR=../../" "PREFIX=../../$(bbu)" install)
        mkdir -p $(bbu)/usr/share/man/man1/
        cp $(bbubd)/docs/BusyBox.1 $(bbu)/usr/share/man/man1/busybox.1
 
@@ -131,7 +130,7 @@ busybox: install
        dh_installdirs
        dh_installdocs       -p$@  $(bbbd)/docs/BusyBox.txt \
                $(bbbd)/docs/BusyBox.html docs/style-guide.txt \
-               docs/busybox.lineo.com AUTHORS README TODO
+               docs/busybox.net AUTHORS README TODO
        rm -rf `find $(bb) -name CVS`
        rm -f `find $(bb) -name .cvsignore`
        dh_installchangelogs -p$@ Changelog
@@ -153,7 +152,7 @@ busybox-static: do_static
        dh_installdirs
        dh_installdocs       -p$@  $(bbsbd)/docs/BusyBox.txt \
                $(bbsbd)/docs/BusyBox.html docs/style-guide.txt \
-               docs/busybox.lineo.com AUTHORS README TODO
+               docs/busybox.net AUTHORS README TODO
        rm -rf `find $(bbs) -name CVS`
        rm -f `find $(bbs) -name .cvsignore`
        dh_installchangelogs -p$@ Changelog
@@ -186,7 +185,7 @@ busybox-udeb: do_udeb
        # Don't write your stupid guesses to debian/files.
        dh_gencontrol        -p$@ -- -fdebian/files~
        # Register file manually.
-       dpkg-distaddfile $(FILENAME) debian-installer $(PRIORITY)
+       dpkg-distaddfile $(FILENAME) debian-installer standard
        dh_md5sums           -p$@
        dh_builddeb          -p$@ --filename=$(FILENAME)