Add in sample inittab file
[oweals/busybox.git] / busybox.spec
index 46bd7f4843d6b6c403249a3d6d8643fbb856d8c4..a8520074ebe63abfacde5689d02a0ee4b4a2e557 100644 (file)
@@ -1,5 +1,5 @@
 Name: busybox
-Version: 0.29alpha
+Version: 0.40
 Release: 1
 Group: System/Utilities
 Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
@@ -7,33 +7,25 @@ Copyright: GPL
 Packager : Erik Andersen <andersen@lineo.com>
 Conflicts: fileutils grep shellutils
 Buildroot: /tmp/%{Name}-%{Version}
-Source: busybox-0.29a1.tar.gz
+Source: %{Name}-%{Version}.tar.gz
 
 %Description
 BusyBox is a suite of "tiny" Unix utilities in a multi-call binary. It
-provides a pretty complete environment that fits on a floppy or in a
-ROM. Just add "ash" (Keith Almquists tiny Bourne shell clone) and "ae",
-and a kernel and you have a full system. This is used on the Debian
-install disk and in an internet router, and it makes a good environment
-for a "rescue" disk or any small or embedded system.
+provides a pretty complete POSIX environment in a very small package.
+Just add a kernel, "ash" (Keith Almquists tiny Bourne shell clone), and
+an editor such as "elvis-tiny" or "ae", and you have a full system. This
+is makes an excellent environment for a "rescue" disk or any small or
+embedded system.
 
 %Prep
-%setup -q -n busybox
+%setup -q -n %{Name}-%{Version}
 
 %Build
-make
+BB_INIT_RC_EXIT_CMD=\"/bin/sh\" BB_INIT_SCRIPT=\"/etc/rc.d/init.d/rcS\" make
 
 %Install
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/bin
-h=`cat busybox.links`
-
-for i in $h ; do
-       mkdir -p $RPM_BUILD_ROOT/`echo $i | sed -e 's/\(^.*\/\)\(.*\)/\1/g' `
-       (cd $RPM_BUILD_ROOT/bin ; ln -s ln `echo $i | sed -e 's/\(^.*\/\)\(.*\)/\2/g' ` ); 
-done 
-rm -f $RPM_BUILD_ROOT/bin/ln
-install -m 755 busybox $RPM_BUILD_ROOT/bin/ln
+make PREFIX=$RPM_BUILD_ROOT install
 
 %Clean
 rm -rf $RPM_BUILD_ROOT