Pavel Roskin <proski@gnu.org> just found a nasty memory
[oweals/busybox.git] / busybox.spec
index 4227256712c87d008e926fb7c39b53fcfefd0812..a7eb86dc1c74a1709c072e4e7012654f0bd6451d 100644 (file)
@@ -1,5 +1,5 @@
 Name: busybox
-Version: 0.32
+Version: 0.45
 Release: 1
 Group: System/Utilities
 Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
@@ -7,33 +7,26 @@ Copyright: GPL
 Packager : Erik Andersen <andersen@lineo.com>
 Conflicts: fileutils grep shellutils
 Buildroot: /tmp/%{Name}-%{Version}
-Source: busybox-0.32.tar.gz
+Source: %{Name}-%{Version}.tar.gz
 
 %Description
-BusyBox is a suite of "tiny" Unix utilities in a multi-call binary. It
-provides a pretty complete POSIX environment in a very small package.
-Just add a kernel, "ash" (Keith Almquists tiny Bourne shell clone), and
-an editor such as "elvis-tiny" or "ae", and you have a full system. This
-is makes an excellent environment for a "rescue" disk or any small or
-embedded system.
+BusyBox combines tiny versions of many common UNIX utilities into a single
+small executable. It provides minimalist replacements for most of the utilities
+you usually find in fileutils, shellutils, findutils, textutils, grep, gzip,
+tar, etc.  BusyBox provides a fairly complete POSIX environment for any small
+or emdedded system.  The utilities in BusyBox generally have fewer options then
+their full featured GNU cousins; however, the options that are provided behave
+very much like their GNU counterparts.
 
 %Prep
-%setup -q -n busybox
+%setup -q -n %{Name}-%{Version}
 
 %Build
 make
 
 %Install
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/bin
-h=`cat busybox.links`
-
-for i in $h ; do
-       mkdir -p $RPM_BUILD_ROOT/`echo $i | sed -e 's/\(^.*\/\)\(.*\)/\1/g' `
-       (cd $RPM_BUILD_ROOT/bin ; ln -s ln `echo $i | sed -e 's/\(^.*\/\)\(.*\)/\2/g' ` ); 
-done 
-rm -f $RPM_BUILD_ROOT/bin/ln
-install -m 755 busybox $RPM_BUILD_ROOT/bin/ln
+make PREFIX=$RPM_BUILD_ROOT install
 
 %Clean
 rm -rf $RPM_BUILD_ROOT