Remove wrong entry from usb ids.
[oweals/hwdata.git] / hwdata.spec
1 # This package is arch-specific just because of bundling different files for
2 # different architectures. No -debuginfo package is needed.
3 %global     debug_package %{nil}
4 %global     uprelease   8.4
5
6 Name:       hwdata
7 Summary:    Hardware identification and configuration data
8 Version:    0.252
9 Release:    %{uprelease}%{?dist}
10 License:    GPLv2+
11 Group:      System Environment/Base
12 Source0:    https://fedorahosted.org/releases/h/w/%{name}/%{name}-%{version}-%{uprelease}.tar.bz2
13 URL:        http://git.fedorahosted.org/git/hwdata.git
14
15 BuildRequires   : perl
16 BuildRequires   : perl(Date::Format)
17
18 Requires        : systemd
19 Requires(post)  : systemd
20 Requires(postun): systemd
21
22 %description
23 hwdata contains various hardware identification and configuration data,
24 such as the pci.ids and usb.ids databases.
25
26 %prep
27 %setup -q -n %{name}-%{version}-%{uprelease}
28 %ifarch ppc ppc64
29 patch -b -B nx_crypto -p1 < blacklist-nx_crypto.patch
30 %endif
31 patch < remove-wrong-usb-id.patch
32 %configure
33
34 %build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_prefix}/lib
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %post
44 udevadm hwdb --update >/dev/null 2>&1 || :
45
46 %postun
47 udevadm hwdb --update >/dev/null 2>&1 || :
48
49 %files
50 %doc LICENSE COPYING
51 %dir %{_datadir}/%{name}
52 %{_prefix}/lib/modprobe.d/dist-blacklist.conf
53 %{_prefix}/lib/udev/hwdb.d/[0-9][0-9]-*.hwdb
54 %{_datadir}/%{name}/*
55
56 %changelog
57 * Thu Sep 29 2016 Vitezslav Crhonek <vcrhonek@redhat.com> - 0.252-8.4
58 - Remove wrong entry from usb ids.
59   Resolves: #1380159
60
61 * Mon Sep 26 2016 Vitezslav Crhonek <vcrhonek@redhat.com> - 0.252-8.3
62 - Updated pci, usb and vendor ids.
63 - Resolves: rhbz#1292382
64
65 * Tue Jun 28 2016 Michal Minar <miminar@redhat.com> 0.252-8.2
66 - Updated pci, usb and vendor ids.
67 - Resolves: rhbz#1292382
68 - Resolves: rhbz#1291614
69 - Resolves: rhbz#1324198
70
71 * Fri Oct 23 2015 Michal Minar <miminar@redhat.com> 0.252-8.1
72 - Updated pci, usb and vendor ids.
73 - Resolves: rhbz#1236458
74 - Resolves: rhbz#1256004
75 - Resolves: rhbz#1266217
76 - Resolves: rhbz#1271797
77
78 * Mon Jun 29 2015 Michal Minar <miminar@redhat.com> 0.252-7.9
79 - Updated pci, usb and vendor ids.
80
81 * Tue Apr 14 2015 Michal Minar <miminar@redhat.com> 0.252-7.8
82 - Blacklisted module nx_crypto on PowerPCs.
83 - Resolves: rhbz#1211389
84 - Disable debuginfo build.
85
86 * Fri Apr 10 2015 Michal Minar <miminar@redhat.com> 0.252-7.6
87 - Blacklisted experimental module sha1-mb.
88 - Resolves: rhbz#1208120
89
90 * Fri Jan 30 2015 Michal Minar <miminar@redhat.com> 0.252-7.5
91 - Updated vendor, usb and pci ids.
92
93 * Mon Sep 22 2014 Michal Minar <miminar@redhat.com> 0.252-7.4
94 - Updated vendor, usb and pci ids.
95
96 * Thu Mar 27 2014 Michal Minar <miminar@redhat.com> 0.252-7.3
97 - Added few more hwdb files.
98 - Updated vendor and pci ids.
99
100 * Thu Mar 20 2014 Michal Minar <miminar@redhat.com> 0.252-7.1
101 - Bumped release to reflect rhel version.
102 - Fixed bogus dates in changelog.
103 - Generate and install hwdb.d/* files.
104
105 * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.252-3
106 - Mass rebuild 2013-12-27
107
108 * Mon Aug 5 2013 Michal Minar <miminar@redhat.com> 0.252-2
109 - Changelog fix.
110
111 * Sun Jul 21 2013 Michal Minar <miminar@redhat.com> 0.252-1
112 - Data files update.
113
114 * Sat Jul 06 2013 Michal Minar <miminar@redhat.com> 0.250-1
115 - Data files update.
116
117 * Thu Jun 20 2013 Michal Minar <miminar@redhat.com> 0.249-1
118 - Data files update, pnp.ids included.
119
120 * Thu Apr 18 2013 Michal Minar <miminar@redhat.com> 0.248-1
121 - Data files update
122
123 * Wed Mar 27 2013 Michal Minar <miminar@redhat.com> 0.247-1
124 - Moved blacklist.conf from /etc/modprobe.d to /usr/lib/modprobe.d.
125 - Renamed it to dist-blacklist.conf.
126 - Data files update
127
128 * Mon Mar 18 2013 Michal Minar <miminar@redhat.com> 0.245-1
129 - Data files update
130
131 * Mon Feb 18 2013 Michal Minar <miminar@redhat.com> 0.244-1
132 - Data files updated
133
134 * Fri Jan 18 2013 Michal Minar <miminar@redhat.com> 0.243-1
135 - Data files updated
136
137 * Fri Dec 07 2012 Michal Minar <miminar@redhat.com> 0.242-1
138 - Update data files
139
140 * Wed Nov 07 2012 Michal Minar <miminar@redhat.com> 0.241-1
141 - Update data files
142
143 * Wed Sep 26 2012 Michal Minar <miminar@redhat.com> 0.240-1
144 - made use of configure script in prep
145
146 * Tue Sep 25 2012 Michal Minar <miminar@redhat.com> 0.239-1
147 - Update data files
148
149 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.238-1
150 - Fix reference specfile to current Fedora style
151
152 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.235-1
153 - Update data files
154 - Remove upgradelist, not needed since kudzu-ectomy
155
156 * Mon Aug 08 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.3
157 - update pci.ids, usb. ids
158
159 * Mon May 02 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.2
160 - update pci.ids with a fix for QLogic Infiniband adapter
161
162 * Wed Apr 27 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.1
163 - update to latest pci.ids, usb.ids
164
165 * Fri Jan 28 2011 Karsten Hopp <karsten@redhat.com> 0.233-7
166 - bump release
167 - update oui.txt URL
168 - fix tarball name in spec file
169 - update usb.ids, out.txt and pci.ids
170
171 * Wed Aug 25 2010 Karsten Hopp <karsten@redhat.com> 0.233-1
172 - update usb.ids, out.txt and pci.ids
173
174 * Thu Aug 05 2010 Karsten Hopp <karsten@redhat.com> 0.232-1
175 - update usb.ids, out.txt and pci.ids (#550020, #611860)
176 - fix incorrect syntax doc/comment in blacklist.conf (Ville Skyttä, #532802)
177 - add Acer B243HL and BenQ G2420HDBL (Ville Skyttä, #590787)
178 - add HP LP2475w and Samsung 2494HM (Ville Skyttä, #595059)
179
180 * Tue May 25 2010 Phil Knirsch <pknirsch@redhat.com> 0.230-1
181 - update usb.ids, out.txt and pci.ids
182 - Resolves: #584788
183
184 * Mon Mar 29 2010 Karsten Hopp <karsten@redhat.com> 0.229-1
185 - update usb.ids, out.txt and pci.ids for F-13 (#571914)
186
187 * Wed Mar 17 2010 Phil Knirsch <pknirsch@redhat.com> 0.228-1
188 - Blacklist chsc_sch for s390x
189 - Resolves: #563228
190
191 * Tue Feb 23 2010 Dave Airlie <airlied@redhat.com> 0.227-1
192 - add viafb to blacklist
193
194 * Mon Feb 22 2010 Karsten Hopp <karsten@redhat.com> 0.227-1
195 - update usb.ids, pci.ids, oui.txt
196 - update license
197
198 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.226-1
199 - update release number
200
201 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.225-4
202 - update usb.ids pci.ids oui.txt
203
204 * Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0.225-3.1
205 - Rebuilt for RHEL 6
206
207 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.225-3
208 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
209
210 * Tue Jul 07 2009 Adam Jackson <ajax@redhat.com> 0.225-2
211 - pnp-dell.patch: Fix Dell's entry in pnp.ids
212
213 * Thu Apr 09 2009 Adam Jackson <ajax@redhat.com> 0.224-1
214 - Update pci.ids, usb.ids, and oui.txt
215 - Add pnp.ids
216
217 * Thu Mar 19 2009 Karsten Hopp <karsten@redhat.com> 0.223-1
218 - update usb.ids pci.ids oui.txt
219 - rename /etc/modprobe.d/blacklist to /etc/modprobe.d/blacklist.conf
220
221 * Wed Jan 28 2009 Karsten Hopp <karsten@redhat.com> 0.222-1
222 - update usb.ids pci.ids oui.txt and build for all current releases
223   Fixes p.e. #465440
224
225 * Wed Jan 21 2009 Karsten Hopp <karsten@redhat.com> 0.221-1
226 - update usb.ids pci.ids oui.txt
227
228 * Tue Dec 02 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
229 - add new monitor entries from Mandriva hardware database (Thierry Vignaud)
230 - make generic entries have properly formated frequencies (Thierry Vignaud)
231 - remove duplicate Dell monitor entries (Thierry Vignaud)
232 - more vendor name fixes
233 - fix extra field in 'Compudyne KD-1500N' definition (Thierry Vignaud)
234 - make Dell monitors case consistent (Thierry Vignaud)
235 - make all GoldStar monitors have the same vendor name (Thierry Vignaud)
236 - add URL of git repository
237 - fix spacing (Thierry Vignaud)
238 - sort MonitorDB file with LANG=C sort -f -t ";" -k1,2
239 - add Samsung SyncMaster 2443BWX (Marc van den Dikkenberg)
240 - add some Lenovo monitors (Im Sza)
241
242 * Wed Jul 23 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
243 - update pci.ids, usb.ids, oui.txt
244 - MonitorsDB: add some Samsung monitors (Ronald Warsow)
245 - MonitorsDB: add Dell E1609W (Matt Domsch)
246 - MonitorsDB: add 7 Dell monitors (Matt Domsch)
247 - MonitorsDB: add a bunch of Hyundai and ImageQuest monitors
248
249 * Mon Jun 09 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
250 - add BenQ FP2091 monitor (Peter Williams)
251 - add a bunch of Hyundai and ImageQuest monitors
252
253 * Mon Jun 02 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
254 - update pci.ids, usb.ids, oui.txt
255 - blacklist snd-pcsp (#448425)
256
257 * Mon May 19 2008 Karsten Hopp <karsten@redhat.com> 0.218-1
258 - add some Acer monitors (Im Sz)
259
260 * Tue Apr 01 2008 Karsten Hopp <karsten@redhat.com> 0.217-1
261 - update pci.ids, oui.txt
262 - update usb.ids, fixes #439963
263 - add HP w1907 LCD monitor, fixes #431359
264 - fix many monitor entries (Stanislav Ievlev, #430276)
265
266
267 * Mon Mar 03 2008 Karsten Hopp <karsten@redhat.com> 0.216-1
268 - update pci.ids, usb.ids (#431658)
269
270 * Tue Jan 29 2008 Phil Knirsch <pknirsch@redhat.com> 0.215-1
271 - Pull new upstream pci.ids
272
273 * Wed Jan 23 2008 Karsten Hopp <karsten@redhat.com> 0.215-1
274 - add HP W2207 monitor
275 - add oui.txt, a list of bluetooth device makers
276
277 * Fri Jan 18 2008 Karsten Hopp <karsten@redhat.com> 0.214-1
278 - remove MonitorsDB.generic as it isn't used anywhere
279 - drop RHEL-5 blacklist patch in -devel
280
281 * Tue Jan 15 2008 Karsten Hopp <karsten@redhat.com> 0.213-1
282 - add many monitor entries (Im Sza, #367111)
283
284 * Fri Jan 11 2008 Karsten Hopp <karsten@redhat.com> 0.212-1
285 - pull new upstream pci.ids, usb.ids
286 - Resolves: #300831
287 - added HP TFT5600 LCD Monitor
288 - Resolves: #250569
289 - added Acer AL1916W, Eizo L568/L568D, Samsung 795DF
290 - Resolves: #250582
291 - Add Samsung 205BW/206BW/225BW/226BW
292 - Resolves: #250584
293 - Add Samsung 931BF
294 - Resolves: #250587
295
296 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
297 - add Proview 926w monitor (#363091)
298
299 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.208-1
300 - new release
301 - drop dell-monitors patch, already included in tarball
302
303 * Thu Dec 13 2007 Karsten Hopp <karsten@redhat.com> 0.207-3
304 - fix License tag
305 - add empty %%build section for fedora-review
306
307 * Thu Oct 25 2007 Matt Domsch <Matt_Domsch@dell.com> 0.207-2
308 - MonitorsDB: add 20 new Dell monitors
309
310 * Wed Sep 26 2007 Karsten Hopp <karsten@redhat.com> 0.211-1
311 - pull new upstream pci.ids, usb.ids
312
313 * Thu Sep 20 2007 Karsten Hopp <karsten@redhat.com> 0.210-1
314 - add pci.id for Chelsio 10GbE Ethernet Adapter
315 - Resolves: bz #296811
316
317 * Wed Sep 19 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
318 - pull new upstream pci.ids, usb.ids
319
320 * Wed Aug 29 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
321 - update license tag
322
323 * Wed Aug 15 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
324 - pull new upstream pci.ids and rebuild
325 - Resolves: bz #251732
326 - Resolves: bz #251734
327 - Resolves: bz #252195
328 - Resolves: bz #252196
329 - Resolves: bz #241274
330
331 * Tue Aug 14 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
332 - add HP TFT5600        #229370
333
334 * Mon Jul 09 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
335 - enable iwl4965 blacklist
336 - Resolves: bz#245379
337
338 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
339 - really update pci.ids, update-pciids downloaded an old file
340 - disable iwl4965 blacklist as it is not approved yet (#245379)
341
342 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.202-1
343 - don't load iwl4965 module automatically
344 - Resolves: #245379
345
346 * Tue Jun 19 2007 Karsten Hopp <karsten@redhat.com> 0.201-1
347 - add some monitors
348 - Resolves: #224511
349 - update pci.ids
350 - Related: #223105
351
352 * Tue Jan 02 2007 Karsten Hopp <karsten@redhat.com> 0.194-1
353 - Update to latest pci.ids/usb.ids for RHEL5
354 - Resolves: #220182
355   Add some Dell monitors to MonitorDB
356
357 * Mon Oct 09 2006 Phil Knirsch <pknirsch@redhat.com> - 0.191-1
358 - Update to latest pci.ids for RHEL5
359
360 * Thu Sep 21 2006 Adam Jackson <ajackson@redhat.com> - 0.190-1
361 - Add a description for the 'intel' driver.
362
363 * Mon Sep 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.189-1
364 - Updated usb.ids for FC6
365
366 * Mon Sep 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.188-1
367 - Update of pci.ids for FC6
368
369 * Thu Aug 31 2006 Adam Jackson <ajackson@redhat.com> - 0.187-1
370 - Fix sync ranges for Samsung SyncMaster 710N (#202344)
371
372 * Thu Aug 03 2006 Phil Knirsch <pknirsch@redhat.com> - 0.186-1
373 - Updated pci.ids once more.
374
375 * Tue Jul 25 2006 Phil Knirsch <pknirsch@redhat.com> - 0.185-1
376 - Added the 17inch Philips LCD monitor entry (#199828)
377
378 * Mon Jul 24 2006 Phil Knirsch <pknirsch@redhat.com> - 0.184-1
379 - Added one more entry for missing Philips LCD monitor (#199828)
380
381 * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.183-1
382 - Updated pci.ids before FC6 final (#198994)
383 - Added several missing Samsung monitors (#197463)
384 - Included a new inf2mondb.py from Matt Domsch (#158723)
385
386 * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> - 0.182-1
387 - Added ast driver description to videodrivers
388 - Numerous Dell monitor additions (#196734)
389 - Numerous Belinea monitor additions (#198087)
390
391 * Sat Jul  8 2006 Adam Jackson <ajackson@redhat.com> - 0.181-1
392 - Updated videodrivers to mention i945
393 - New monitors: Sony CPD-G420 (#145902), Compaq P1110 (#155120).
394
395 * Thu May 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.180-1
396 - Updated and added some MonitorsDB entries
397
398 * Tue May 02 2006 Phil Knirsch <pknirsch@redhat.com> - 0.179-1
399 - Updated PCI ids from upstream (#180402)
400 - Fixed missing monitor entry in MonitorsDB (#189446)
401
402 * Wed Mar 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.178-1
403 - Commented out the VT lines at the end of usb.ids as our tools don't handle
404   them properly.
405
406 * Fri Feb 24 2006 Bill Nottingham <notting@redhat.com> - 0.177-1
407 - remove stock videoaliases in favor of driver-specific ones in
408   the X driver packages
409
410 * Wed Feb 22 2006 Phil Knirsch <pknirsch@redhat.com> - 0.176-1
411 - More entries from Dell to MonitorsDB (#181008)
412
413 * Fri Feb 10 2006 Phil Knirsch <pknirsch@redhat.com> - 0.175-1
414 - Added a few more entries to MonitorsDB
415
416 * Wed Feb 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.174-1
417 - Some cleanup and adds to the MonitorDB which closes several db related bugs.
418
419 * Tue Dec 13 2005 Bill Nottingham <notting@redhat.com> - 0.173-1
420 - add some IDs to the generic display entries for matching laptops
421
422 * Fri Nov 18 2005 Bill Nottingham <notting@redhat.com> - 0.172-1
423 - ditto for radeon
424
425 * Fri Nov 18 2005 Jeremy Katz <katzj@redhat.com> - 0.171-1
426 - r128 -> ati.  should fix the unresolved symbol and kem says its more 
427   generally the "right" thing to do
428
429 * Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 0.170-1
430 - handle mptsas for migration as well
431 - move videoaliases file to a subdir
432
433 * Fri Sep 16 2005 Bill Nottingham <notting@redhat.com>
434 - add Iiyama monitor (#168143)
435
436 * Tue Sep 13 2005 Bill Nottingham <notting@redhat.com>
437 - add IBM monitor (#168080)
438
439 * Thu Sep  8 2005 Bill Nottingham <notting@redhat.com> - 0.169-1
440 - remove Cards, pcitable. Add videodrivers
441
442 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.168-1
443 - Add more Gateway monitors
444
445 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.167-1
446 - Add some ADI monitors, one BenQ, and and DPMS codes for two Apples
447
448 * Fri Sep  2 2005 Bill Nottingham <notting@redhat.com> - 0.166-1
449 - add videoaliases file
450 - remove CardMonitorCombos, as nothing uses it
451
452 * Thu Aug 25 2005 Dan Williams <dcbw@redhat.com> - 0.165-1
453 - Add a bunch of Acer monitors
454
455 * Tue Aug  9 2005 Jeremy Katz <katzj@redhat.com> - 0.164-1
456 - migrate sk98lin -> skge
457
458 * Sat Jul 30 2005 Bill Nottingham <notting@redhat.com>
459 - migrate mpt module names (#161420)
460 - remove pcitable entries for drivers in modules.pcimap
461 - switch lone remaining 'Server' entry - that can't work right
462
463 * Tue Jul 26 2005 Bill Nottingham <notting@redhat.com>
464 - add Daytek monitor (#164339)
465
466 * Wed Jul 13 2005 Bill Nottingham <notting@redhat.com> - 0.162-1
467 - remove /etc/pcmcia/config, conflict with pcmcia-cs
468
469 * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> - 0.160-1
470 - move blacklist to /etc/modprobe.d, require new module-init-tools
471 - add LG monitors (#162466, #161734)
472 - add orinoco card (#161696)
473 - more mptfusion stuff (#107088)
474
475 * Thu Jun 23 2005 Bill Nottingham <notting@redhat.com>
476 - add Samsung monitor (#161013)
477
478 * Wed Jun 22 2005 Bill Nottingham <notting@redhat.com> - 0.159-1
479 - pcitable: make branding happy (#160047)
480 - Cards: add required blank line (#157972)
481 - add some monitors
482 - add JVC CD-ROM (#160907, <richard@rsk.demon.co.uk>)
483 - add hisax stuff to blacklist (#154799, #159068)
484
485 * Mon May 16 2005 Bill Nottingham <notting@redhat.com> - 0.158-1
486 - add a orinoco card (#157482)
487
488 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 0.157-1
489 - add 20" Apple Cinema Display
490
491 * Sun Apr 10 2005 Mike A. Harris <mharris@redhat.com> 0.156-1
492 - Update SiS entries in Cards/pcitable to match what Xorg X11 6.8.2 supports
493
494 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.155-1
495 - Add a boatload of BenQ, Acer, Sony, NEC, Mitsubishi, and Dell monitors
496
497 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.154-1
498 - Add Typhoon Speednet Wireless PCMCIA Card mapping to atmel_cs driver
499
500 * Mon Mar 28 2005 Bill Nottingham <notting@redhat.com> 0.153-1
501 - update the framebuffer blacklist
502
503 * Wed Mar  9 2005 Bill Nottingham <notting@redhat.com> 0.152-1
504 - fix qlogic driver mappings, add upgradelist mappings for the modules
505   that changed names (#150621)
506
507 * Wed Mar  2 2005 Mike A. Harris <mharris@redhat.com> 0.151-1
508 - Added one hundred billion new nvidia PCI IDs to pcitable and Cards to
509   synchronize it with X.Org X11 6.8.2.  (#140601)
510
511 * Tue Jan 11 2005 Dan Williams <dcbw@redhat.com> - 0.150-1
512 - Add Dell UltraSharp 1704FPV (Analog & Digital)
513
514 * Sun Nov 21 2004 Bill Nottingham <notting@redhat.com> - 0.148-1
515 - add Amptron monitors (#139142)
516
517 * Wed Nov 10 2004 Bill Nottingham <notting@redhat.com> - 0.147-1
518 - update usb.ids (#138533)
519 - migrate dpt_i2o to i2o_block (#138603)
520
521 * Tue Nov  9 2004 Bill Nottingham <notting@redhat.com> - 0.146-1
522 - update pci.ids (#138233)
523 - add Apple monitors (#138481)
524
525 * Wed Oct 20 2004 Bill Nottingham <notting@redhat.com> - 0.145-1
526 - remove ahci mappings, don't prefer it over ata_piix
527
528 * Tue Oct 19 2004 Kristian Høgsberg <krh@redhat.com> - 0.144-1
529 - update IDs for Cirrus, Trident, C&T, and S3
530
531 * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> - 0.143-1
532 - add ahci mappings to prefer it over ata_piix
533 - map davej's ancient matrox card to vesa (#122750)
534
535 * Thu Oct  7 2004 Dan Williams <dcbw@redhat.com> - 0.141-1
536 - Add Belkin F5D6020 ver.2 (802.11b card based on Atmel chipset)
537
538 * Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> - 0.140-1
539 - include /etc/hotplug/blacklist here
540
541 * Thu Sep 30 2004 Bill Nottingham <notting@redhat.com> - 0.136-1
542 - add S3 UniChrome (#131403)
543 - update pci.ids
544
545 * Thu Sep 23 2004 Bill Nottingham <notting@redhat.com> - 0.135-1
546 - megaraid -> megaraid_mbox
547
548 * Wed Sep 22 2004 Bill Nottingham <notting@redhat.com> - 0.134-1
549 - map ncr53c8xx to sym53c8xx (#133181)
550
551 * Fri Sep 17 2004 Bill Nottingham <notting@redhat.com> - 0.132-1
552 - fix 3Ware 9000 mapping (#132851)
553
554 * Tue Sep 14 2004 Kristian Høgsberg <krh@redhat.com> - 0.131-1
555 - Add python script to check sorting of pci.ids
556
557 * Thu Sep  9 2004 Kristian Høgsberg <krh@redhat.com> 0.131-1
558 - Add pci ids and cards for new ATI, NVIDIA and Intel cards
559
560 * Sat Sep  4 2004 Bill Nottingham <notting@redhat.com> 0.130-1
561 - trim pcitable - now just ids/drivers
562
563 * Wed Sep  1 2004 Bill Nottingham <notting@redhat.com> 0.125-1
564 - pci.ids updates
565 - remove updsftab.conf.*
566
567 * Sun Aug 29 2004 Mike A. Harris <mharris@redhat.com>  0.124-1
568 - Updates to pcitable/Cards for 'S3 Trio64 3D' cards. (#125866,59956)
569
570 * Fri Jul  9 2004 Mike A. Harris <mharris@redhat.com>  0.123-1
571 - Quick pcitable/Cards update for ATI Radeon and FireGL boards
572
573 * Mon Jun 28 2004 Bill Nottingham <notting@redhat.com>
574 - add Proview monitor (#125853)
575 - add ViewSonic monitor (#126324)
576 - add a Concord camera (#126673)
577
578 * Wed Jun 23 2004 Brent Fox <bfox@redhat.com> - 0.122-1
579 - Add Vobis monitor to MonitorsDB (bug #124151)
580
581 * Wed Jun 09 2004 Dan Williams <dcbw@redhat.com> - 0.121-1
582 - add Belkin F5D5020 10/100 PCMCIA card (#125581)
583
584 * Fri May 28 2004 Bill Nottingham <notting@redhat.com>
585 - add modem (#124663)
586
587 * Mon May 24 2004 Bill Nottingham <notting@redhat.com> - 0.120-1
588 - mainly:
589   fix upgradelist module for CMPci cards (#123647)
590 - also:
591   add another wireless card (#122676)
592   add wireless card (#122625)
593   add 1280x800 (#121548)
594   add 1680x1050 (#121148)
595   add IntelligentStick (#124313)
596
597 * Mon May 10 2004 Jeremy Katz <katzj@redhat.com> - 0.119-1
598 - veth driver is iseries_veth in 2.6
599
600 * Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 0.118-1
601 - add a wireless card (#122064)
602 - and a monitor (#121696)
603
604 * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.117-1
605 - fix makefile
606
607 * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 0.116-1
608 - move updfstab.conf here
609 - add wireless card (#116865)
610 - add laptop display panel (#117385)
611 - add clipdrive (#119928)
612 - add travelling disk (#119143)
613 - add NEXDISK (#106782)
614
615 * Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 0.115-1
616 - replace snd-es1960 driver with snd-es1968 in pcitable (bug #120729)
617
618 * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 0.114-1
619 - fix entries pointing to Banshee (#119388)
620
621 * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.113-1
622 - add a Marvell sk98lin card (#118467, <64bit_fedora@comcast.net>)
623
624 * Fri Mar 12 2004 Brent Fox <bfox@redhat.com> 0.112-1
625 - add a Sun flat panel to MonitorsDB (bug #118138)
626
627 * Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 0.111-1
628 - add Samsung monitor to MonitorsDB (bug #112112)
629
630 * Mon Mar  1 2004 Mike A. Harris <mharris@redhat.com> 0.110-1
631 - Added 3Dfx Voodoo Graphics and Voodoo II entries to the Cards database, both
632   pointing to Alan Cox's new "voodoo" driver which is now included in XFree86
633   4.3.0-62 and later builds in Fedora development.  Mapped their PCI IDs to
634   the new Cards entry in pcitable.
635 - Updated the entries for 3Dfx Banshee
636
637 * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 0.109-1
638 - pci.ids and other updates
639
640 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.108-1
641 - Added Shamrock C407L to MonitorsDB for bug (#104920)
642
643 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.107-1
644 - Massive Viewsonic monitor update for MonitorsDB (#84882)
645
646 * Fri Feb 13 2004 John Dennis <jdennis@finch.boston.redhat.com> 0.106-1
647 - fix typo, GP should have been HP
648
649 * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 0.105-1
650 - many monitor updates (#114260, #114216, #113993, #113932, #113782,
651   #113685, #113523, #111203, #107788, #106526, #63005)
652 - add some PCMCIA cards (#113006, #112505)
653
654 * Tue Jan 20 2004 Bill Nottingham <notting@redhat.com> 0.104-1
655 - switch sound module mappings to alsa drivers
656
657 * Mon Jan 19 2004 Brent Fox <bfox@redhat.com> 0.103-1
658 - fix tab spacing
659
660 * Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.102-1
661 - added an entry for ATI Radeon 9200SE (bug #111306)
662
663 * Sun Oct 26 2003 Jeremy Katz <katzj@redhat.com> 0.101-1
664 - add 1920x1200 Generic LCD as used on some Dell laptops (#108006)
665
666 * Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.100-1
667 - add entry for Sun (made by Samsung) monitor (bug #107128)
668
669 * Tue Sep 23 2003 Mike A. Harris <mharris@redhat.com> 0.99-1
670 - Added entries for Radeon 9600/9600Pro/9800Pro to Cards
671 - Fixed minor glitch in pcitable for Radeon 9500 Pro
672
673 * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
674 - add VMWare display adapter pci id and map to vmware X driver
675
676 * Thu Sep 11 2003 Bill Nottingham <notting@redhat.com> 0.97-1
677 - bcm4400 -> b44
678
679 * Sun Sep  7 2003 Bill Nottingham <notting@redhat.com> 0.96-1
680 - fix provided Dell tweaks (#103892)
681
682 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.95-1
683 - Dell tweaks (#103861)
684
685 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.94-1
686 - add adaptec pci id (#100844)
687
688 * Thu Sep  4 2003 Brent Fox <bfox@redhat.com> 0.93-1
689 - add an SGI monitor for bug (#74870)
690
691 * Wed Aug 27 2003 Bill Nottingham <notting@redhat.com> 0.92-1
692 - updates from sourceforge.net pci.ids, update pcitable accordingly
693
694 * Mon Aug 18 2003 Mike A. Harris <mharris@redhat.com> 0.91-1
695 - Added HP monitors for bug (#102495)
696
697 * Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 0.90-1
698 - added a sony monitor (bug #101550)
699
700 * Tue Jul 15 2003 Bill Nottingham <notting@redhat.com> 0.89-1
701 - updates from modules.pcimap
702
703 * Sat Jul 12 2003 Mike A. Harris <mharris@redhat.com> 0.88-1
704 - Update MonitorsDB for new IBM monitors from upstream XFree86 bugzilla:
705   http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=459
706
707 * Mon Jun  9 2003 Bill Nottingham <notting@redhat.com> 0.87-1
708 - fusion update
709
710 * Mon Jun  9 2003 Jeremy Katz <katzj@redhat.com> 0.86-1
711 - pci id for ata_piix
712
713 * Wed Jun  4 2003 Brent Fox <bfox@redhat.com> 0.85-1
714 - correct entry for Dell P991 monitor
715
716 * Tue Jun  3 2003 Bill Nottingham <notting@redhat.com> 0.84-1
717 - fix qla2100 mapping (#91476)
718 - add dell mappings (#84069)
719
720 * Mon Jun  2 2003 John Dennis <jdennis@redhat.com>
721 - Add new Compaq and HP monitors - bug 90570, bug 90707, bug 90575, IT 17231
722
723 * Wed May 21 2003 Brent Fox <bfox@redhat.com> 0.81-1
724 - add an entry for SiS 650 video card (bug #88271)
725
726 * Wed May 21 2003 Michael Fulbright <msf@redhat.com> 0.80-1
727 - Changed Generic monitor entries in MonitorsDB to being in LCD and CRT groups
728
729 * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 0.79-1
730 - pci.ids and usb.ids updates
731
732 * Tue May  6 2003 Brent Fox <bfox@redhat.com> 0.78-1
733 - added a Samsung monitor to MonitorsDB
734
735 * Fri May  2 2003 Bill Nottingham <notting@redhat.com>
736 - add Xircom wireless airo_cs card (#90099)
737
738 * Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.77-1
739 - add generic framebuffer to Cards
740
741 * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 0.76-1
742 - Updated MonitorsDb for Dell monitors (#86072)
743
744 * Tue Feb 18 2003 Mike A. Harris <mharris@redhat.com> 0.75-1
745 - Change savage MX and IX driver default back to "savage" for the 1.1.27t
746   driver update
747   
748 * Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 0.74-1
749 - Use full resolution description for Dell laptop screens (bug #80398)
750
751 * Thu Feb 13 2003 Mike A. Harris <mharris@redhat.com> 0.73-1
752 - Updated pcitable and Cards database to fix Savage entries up a bit, and
753   change default Savage/MX driver to 'vesa' as it is hosed and with no sign
754   of working in time for 4.3.0.  Fixes (#72476,80278,80346,80423,82394)
755
756 * Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.72-1
757 - slightly alter the sync rates for the Dell 1503FP (bug #84123)
758
759 * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 0.71-1
760 - large pcitable and pci.ids updates
761 - more tg3, e100
762
763 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.69-1
764 - Updated pcitable and Cards database for new Intel i852/i855/i865 support
765
766 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.68-1
767 - Massive update of all ATI video hardware PCI IDs in pcitable and a fair
768   number of additions and corrections to the Cards database as well
769   
770 * Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 0.67-1
771 - change refresh rates of sny0000 monitors to use a low common denominator
772
773 * Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 0.66-1
774 - don't force DRI off on R200 (#82957)
775
776 * Fri Jan 24 2003 Mike A. Harris <mharris@redhat.com> 0.65-1
777 - Added Card:S3 Trio64V2 (Unsupported RAMDAC) entry to pcitable, pci.ids, and
778   Cards database to default this particular variant to "vesa" driver (#81659)
779
780 * Thu Jan  2 2003 Bill Nottingham <notting@redhat.com> 0.64-1
781 - pci.ids and associated pcitable updates
782
783 * Sun Dec 29 2002 Mike A. Harris <mharris@redhat.com> 0.63-1
784 - Updates for GeForce 2 Go, GeForce 4 (#80209)
785
786 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-2
787 - fix Cards for NatSemi Geode
788
789 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-1
790 - use e100 instead of eepro100 for pcmcia
791
792 * Mon Nov 25 2002 Mike A. Harris <mharris@redhat.com>
793 - Complete reconstruction of all Neomagic hardware entries in Cards
794   database to reflect current XFree86, as well as pcitable update,
795   and submitted cleaned up entries to sourceforge
796
797 * Mon Nov  4 2002 Bill Nottingham <notting@redhat.com> 0.61-1
798 - move pcmcia config file here
799 - sort MonitorsDB, add some entries, remove dups
800 - switch some network driver mappings
801
802 * Tue Sep 24 2002 Bill Nottingham <notting@redhat.com> 0.48-1
803 - broadcom 5704 mapping
804 - aic79xx (#73781)
805
806 * Thu Sep  5 2002 Bill Nottingham <notting@redhat.com> 0.47-1
807 - pci.ids updates
808 - add msw's wireless card
809
810 * Tue Sep  3 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
811 - Card entries in pcitable need matching in Cards
812
813 * Sun Sep  1 2002 Mike A. Harris <mharris@redhat.com> 0.45-1
814 - Update G450 entry in Cards
815
816 * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 0.44-1
817 - fix some of the Dell entries
818 - add cardbus controller id (#71198)
819 - add audigy mapping
820 - add NEC monitor (#71320)
821
822 * Tue Aug 13 2002 Preston Brown <pbrown@redhat.com> 0.43-1
823 - pci.id for SMC wireless PCI card (#67346)
824
825 * Sat Aug 10 2002 Mike A. Harris <mharris@redhat.com> 0.42-1
826 - Change default driver for old S3 based "Miro" card for bug (#70743)
827
828 * Fri Aug  9 2002 Preston Brown <pbrown@redhat.com> 0.41-1
829 - fix tabs in pci.ids
830 - Change pci ids for the PowerEdge 4 series again...
831
832 * Tue Aug  6 2002 Preston Brown <pbrown@redhat.com> 0.39-1
833 - Dell PERC and SCSI pci.id additions
834
835 * Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 0.38-1
836 - Removed and/or invalid entries from Cards database BLOCKER (#70802)
837
838 * Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 0.37-1
839 - Changed Matrox G450 driver default options to fix bug (#66697)
840 - Corrected S3 Trio64V2 bug in Cards file (#66492)
841
842 * Tue Jul 30 2002 Bill Nottingham <notting@redhat.com> 0.36-1
843 - tweaks for Dell Remote Assisstant cards (#60376)
844
845 * Fri Jul 26 2002 Mike A. Harris <mharris@redhat.com> 0.35-1
846 - Updated Cards db for CT69000
847 - Various ATI cleanups and additions to Cards and pcitable
848 - Updated S3 Trio3D to default to "vesa" driver (#59956)
849
850 * Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.33-1
851 - Eizo monitor updates (#56080, <triad@df.lth.se>)
852 - pci.ids updates, corresponding pcitable updates
853 - pcilint for pcitable 
854
855 * Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 0.32-1
856 - switch de4x5 back to tulip
857
858 * Mon Jun 24 2002 Mike A. Harris <mharris@redhat.com> 0.31-1
859 - Modified ATI entries in pcitable to be able to autodetect the FireGL 8700
860   and FireGL 8800 which both have the same ID, but different subdevice ID's.
861   Added entries to Cards database for the 8700/8800 as well.
862
863 * Tue May 28 2002 Mike A. Harris <mharris@redhat.com> 0.30-1
864 - Reconfigured Cards database to default to XFree86 4.x for ALL video
865   hardware, since 3.3.6 support is being removed.  Video cards not
866   supported natively by 4.x will be changed to use the vesa or vga
867   driver, or completely removed as unsupported.
868
869 * Wed Apr 17 2002 Michael Fulbright <msf@redhat.com> 0.14-1
870 - another megaraid variant
871
872 * Mon Apr 15 2002 Michael Fulbright <msf@redhat.com> 0.13-1
873 - fix monitor entry for Dell 1600X Laptop Display Panel
874
875 * Fri Apr 12 2002 Bill Nottingham <notting@redhat.com> 0.13-1
876 - more aacraid
877
878 * Tue Apr  9 2002 Bill Nottingham <notting@redhat.com> 0.12-1
879 - another 3ware, another megaraid
880
881 * Fri Apr  5 2002 Mike A. Harris <mharris@redhat.com> 0.11-1
882 - Added commented out line for some Radeon 7500 cards to Cards database.
883
884 * Tue Apr  2 2002 Mike A. Harris <mharris@redhat.com> 0.10-1
885 - Fixed i830 entry to use driver "i810" not "i830" which doesn't exist
886
887 * Mon Apr  1 2002 Bill Nottingham <notting@redhat.com> 0.9-1
888 - fix rebuild (#62459)
889 - SuperSavage ids (#62101)
890 - updates from pci.ids
891
892 * Mon Mar 18 2002 Bill Nottingham <notting@redhat.com> 0.8-2
893 - fix errant space (#61363)
894
895 * Thu Mar 14 2002 Bill Nottingham <notting@redhat.com> 0.8-1
896 - nVidia updates
897
898 * Wed Mar 13 2002 Bill Nottingham <notting@redhat.com> 0.7-1
899 - lots of pcitable updates
900
901 * Tue Mar  5 2002 Mike A. Harris <mharris@redhat.com> 0.6-1
902 - Updated Cards database
903
904 * Mon Mar  4 2002 Mike A. Harris <mharris@redhat.com> 0.5-1
905 - Built new package with updated database files for rawhide.
906
907 * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 0.3-1
908 - return of XFree86-3.3.x
909
910 * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 0.1-1
911 - initial build