f4a83be2e116843a46dd50156239bf2a3473d872
[oweals/hwdata.git] / hwdata.spec
1 # This package is arch-specific just because of bundling different files for
2 # different architectures. No -debuginfo package is needed.
3 %global     debug_package %{nil}
4 %global     uprelease   8.2
5
6 Name:       hwdata
7 Summary:    Hardware identification and configuration data
8 Version:    0.252
9 Release:    %{uprelease}%{?dist}
10 License:    GPLv2+
11 Group:      System Environment/Base
12 Source0:    https://fedorahosted.org/releases/h/w/%{name}/%{name}-%{version}-%{uprelease}.tar.bz2
13 URL:        http://git.fedorahosted.org/git/hwdata.git
14
15 BuildRequires   : perl
16 BuildRequires   : perl(Date::Format)
17
18 Requires        : systemd
19 Requires(post)  : systemd
20 Requires(postun): systemd
21
22 %description
23 hwdata contains various hardware identification and configuration data,
24 such as the pci.ids and usb.ids databases.
25
26 %prep
27 %setup -q -n %{name}-%{version}-%{uprelease}
28 %ifarch ppc ppc64
29 patch -b -B nx_crypto -p1 < blacklist-nx_crypto.patch
30 %endif
31 %configure
32
33 %build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_prefix}/lib
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 udevadm hwdb --update >/dev/null 2>&1 || :
44
45 %postun
46 udevadm hwdb --update >/dev/null 2>&1 || :
47
48 %files
49 %doc LICENSE COPYING
50 %dir %{_datadir}/%{name}
51 %{_prefix}/lib/modprobe.d/dist-blacklist.conf
52 %{_prefix}/lib/udev/hwdb.d/[0-9][0-9]-*.hwdb
53 %{_datadir}/%{name}/*
54
55 %changelog
56 * Tue Jun 28 2016 Michal Minar <miminar@redhat.com> 0.252-8.2
57 - Updated pci, usb and vendor ids.
58 - Resolves: rhbz#1292382
59 - Resolves: rhbz#1291614
60 - Resolves: rhbz#1324198
61
62 * Fri Oct 23 2015 Michal Minar <miminar@redhat.com> 0.252-8.1
63 - Updated pci, usb and vendor ids.
64 - Resolves: rhbz#1236458
65 - Resolves: rhbz#1256004
66 - Resolves: rhbz#1266217
67 - Resolves: rhbz#1271797
68
69 * Mon Jun 29 2015 Michal Minar <miminar@redhat.com> 0.252-7.9
70 - Updated pci, usb and vendor ids.
71
72 * Tue Apr 14 2015 Michal Minar <miminar@redhat.com> 0.252-7.8
73 - Blacklisted module nx_crypto on PowerPCs.
74 - Resolves: rhbz#1211389
75 - Disable debuginfo build.
76
77 * Fri Apr 10 2015 Michal Minar <miminar@redhat.com> 0.252-7.6
78 - Blacklisted experimental module sha1-mb.
79 - Resolves: rhbz#1208120
80
81 * Fri Jan 30 2015 Michal Minar <miminar@redhat.com> 0.252-7.5
82 - Updated vendor, usb and pci ids.
83
84 * Mon Sep 22 2014 Michal Minar <miminar@redhat.com> 0.252-7.4
85 - Updated vendor, usb and pci ids.
86
87 * Thu Mar 27 2014 Michal Minar <miminar@redhat.com> 0.252-7.3
88 - Added few more hwdb files.
89 - Updated vendor and pci ids.
90
91 * Thu Mar 20 2014 Michal Minar <miminar@redhat.com> 0.252-7.1
92 - Bumped release to reflect rhel version.
93 - Fixed bogus dates in changelog.
94 - Generate and install hwdb.d/* files.
95
96 * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.252-3
97 - Mass rebuild 2013-12-27
98
99 * Mon Aug 5 2013 Michal Minar <miminar@redhat.com> 0.252-2
100 - Changelog fix.
101
102 * Sun Jul 21 2013 Michal Minar <miminar@redhat.com> 0.252-1
103 - Data files update.
104
105 * Sat Jul 06 2013 Michal Minar <miminar@redhat.com> 0.250-1
106 - Data files update.
107
108 * Thu Jun 20 2013 Michal Minar <miminar@redhat.com> 0.249-1
109 - Data files update, pnp.ids included.
110
111 * Thu Apr 18 2013 Michal Minar <miminar@redhat.com> 0.248-1
112 - Data files update
113
114 * Wed Mar 27 2013 Michal Minar <miminar@redhat.com> 0.247-1
115 - Moved blacklist.conf from /etc/modprobe.d to /usr/lib/modprobe.d.
116 - Renamed it to dist-blacklist.conf.
117 - Data files update
118
119 * Mon Mar 18 2013 Michal Minar <miminar@redhat.com> 0.245-1
120 - Data files update
121
122 * Mon Feb 18 2013 Michal Minar <miminar@redhat.com> 0.244-1
123 - Data files updated
124
125 * Fri Jan 18 2013 Michal Minar <miminar@redhat.com> 0.243-1
126 - Data files updated
127
128 * Fri Dec 07 2012 Michal Minar <miminar@redhat.com> 0.242-1
129 - Update data files
130
131 * Wed Nov 07 2012 Michal Minar <miminar@redhat.com> 0.241-1
132 - Update data files
133
134 * Wed Sep 26 2012 Michal Minar <miminar@redhat.com> 0.240-1
135 - made use of configure script in prep
136
137 * Tue Sep 25 2012 Michal Minar <miminar@redhat.com> 0.239-1
138 - Update data files
139
140 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.238-1
141 - Fix reference specfile to current Fedora style
142
143 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.235-1
144 - Update data files
145 - Remove upgradelist, not needed since kudzu-ectomy
146
147 * Mon Aug 08 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.3
148 - update pci.ids, usb. ids
149
150 * Mon May 02 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.2
151 - update pci.ids with a fix for QLogic Infiniband adapter
152
153 * Wed Apr 27 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.1
154 - update to latest pci.ids, usb.ids
155
156 * Fri Jan 28 2011 Karsten Hopp <karsten@redhat.com> 0.233-7
157 - bump release
158 - update oui.txt URL
159 - fix tarball name in spec file
160 - update usb.ids, out.txt and pci.ids
161
162 * Wed Aug 25 2010 Karsten Hopp <karsten@redhat.com> 0.233-1
163 - update usb.ids, out.txt and pci.ids
164
165 * Thu Aug 05 2010 Karsten Hopp <karsten@redhat.com> 0.232-1
166 - update usb.ids, out.txt and pci.ids (#550020, #611860)
167 - fix incorrect syntax doc/comment in blacklist.conf (Ville Skyttä, #532802)
168 - add Acer B243HL and BenQ G2420HDBL (Ville Skyttä, #590787)
169 - add HP LP2475w and Samsung 2494HM (Ville Skyttä, #595059)
170
171 * Tue May 25 2010 Phil Knirsch <pknirsch@redhat.com> 0.230-1
172 - update usb.ids, out.txt and pci.ids
173 - Resolves: #584788
174
175 * Mon Mar 29 2010 Karsten Hopp <karsten@redhat.com> 0.229-1
176 - update usb.ids, out.txt and pci.ids for F-13 (#571914)
177
178 * Wed Mar 17 2010 Phil Knirsch <pknirsch@redhat.com> 0.228-1
179 - Blacklist chsc_sch for s390x
180 - Resolves: #563228
181
182 * Tue Feb 23 2010 Dave Airlie <airlied@redhat.com> 0.227-1
183 - add viafb to blacklist
184
185 * Mon Feb 22 2010 Karsten Hopp <karsten@redhat.com> 0.227-1
186 - update usb.ids, pci.ids, oui.txt
187 - update license
188
189 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.226-1
190 - update release number
191
192 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.225-4
193 - update usb.ids pci.ids oui.txt
194
195 * Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0.225-3.1
196 - Rebuilt for RHEL 6
197
198 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.225-3
199 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
200
201 * Tue Jul 07 2009 Adam Jackson <ajax@redhat.com> 0.225-2
202 - pnp-dell.patch: Fix Dell's entry in pnp.ids
203
204 * Thu Apr 09 2009 Adam Jackson <ajax@redhat.com> 0.224-1
205 - Update pci.ids, usb.ids, and oui.txt
206 - Add pnp.ids
207
208 * Thu Mar 19 2009 Karsten Hopp <karsten@redhat.com> 0.223-1
209 - update usb.ids pci.ids oui.txt
210 - rename /etc/modprobe.d/blacklist to /etc/modprobe.d/blacklist.conf
211
212 * Wed Jan 28 2009 Karsten Hopp <karsten@redhat.com> 0.222-1
213 - update usb.ids pci.ids oui.txt and build for all current releases
214   Fixes p.e. #465440
215
216 * Wed Jan 21 2009 Karsten Hopp <karsten@redhat.com> 0.221-1
217 - update usb.ids pci.ids oui.txt
218
219 * Tue Dec 02 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
220 - add new monitor entries from Mandriva hardware database (Thierry Vignaud)
221 - make generic entries have properly formated frequencies (Thierry Vignaud)
222 - remove duplicate Dell monitor entries (Thierry Vignaud)
223 - more vendor name fixes
224 - fix extra field in 'Compudyne KD-1500N' definition (Thierry Vignaud)
225 - make Dell monitors case consistent (Thierry Vignaud)
226 - make all GoldStar monitors have the same vendor name (Thierry Vignaud)
227 - add URL of git repository
228 - fix spacing (Thierry Vignaud)
229 - sort MonitorDB file with LANG=C sort -f -t ";" -k1,2
230 - add Samsung SyncMaster 2443BWX (Marc van den Dikkenberg)
231 - add some Lenovo monitors (Im Sza)
232
233 * Wed Jul 23 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
234 - update pci.ids, usb.ids, oui.txt
235 - MonitorsDB: add some Samsung monitors (Ronald Warsow)
236 - MonitorsDB: add Dell E1609W (Matt Domsch)
237 - MonitorsDB: add 7 Dell monitors (Matt Domsch)
238 - MonitorsDB: add a bunch of Hyundai and ImageQuest monitors
239
240 * Mon Jun 09 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
241 - add BenQ FP2091 monitor (Peter Williams)
242 - add a bunch of Hyundai and ImageQuest monitors
243
244 * Mon Jun 02 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
245 - update pci.ids, usb.ids, oui.txt
246 - blacklist snd-pcsp (#448425)
247
248 * Mon May 19 2008 Karsten Hopp <karsten@redhat.com> 0.218-1
249 - add some Acer monitors (Im Sz)
250
251 * Tue Apr 01 2008 Karsten Hopp <karsten@redhat.com> 0.217-1
252 - update pci.ids, oui.txt
253 - update usb.ids, fixes #439963
254 - add HP w1907 LCD monitor, fixes #431359
255 - fix many monitor entries (Stanislav Ievlev, #430276)
256
257
258 * Mon Mar 03 2008 Karsten Hopp <karsten@redhat.com> 0.216-1
259 - update pci.ids, usb.ids (#431658)
260
261 * Tue Jan 29 2008 Phil Knirsch <pknirsch@redhat.com> 0.215-1
262 - Pull new upstream pci.ids
263
264 * Wed Jan 23 2008 Karsten Hopp <karsten@redhat.com> 0.215-1
265 - add HP W2207 monitor
266 - add oui.txt, a list of bluetooth device makers
267
268 * Fri Jan 18 2008 Karsten Hopp <karsten@redhat.com> 0.214-1
269 - remove MonitorsDB.generic as it isn't used anywhere
270 - drop RHEL-5 blacklist patch in -devel
271
272 * Tue Jan 15 2008 Karsten Hopp <karsten@redhat.com> 0.213-1
273 - add many monitor entries (Im Sza, #367111)
274
275 * Fri Jan 11 2008 Karsten Hopp <karsten@redhat.com> 0.212-1
276 - pull new upstream pci.ids, usb.ids
277 - Resolves: #300831
278 - added HP TFT5600 LCD Monitor
279 - Resolves: #250569
280 - added Acer AL1916W, Eizo L568/L568D, Samsung 795DF
281 - Resolves: #250582
282 - Add Samsung 205BW/206BW/225BW/226BW
283 - Resolves: #250584
284 - Add Samsung 931BF
285 - Resolves: #250587
286
287 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
288 - add Proview 926w monitor (#363091)
289
290 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.208-1
291 - new release
292 - drop dell-monitors patch, already included in tarball
293
294 * Thu Dec 13 2007 Karsten Hopp <karsten@redhat.com> 0.207-3
295 - fix License tag
296 - add empty %%build section for fedora-review
297
298 * Thu Oct 25 2007 Matt Domsch <Matt_Domsch@dell.com> 0.207-2
299 - MonitorsDB: add 20 new Dell monitors
300
301 * Wed Sep 26 2007 Karsten Hopp <karsten@redhat.com> 0.211-1
302 - pull new upstream pci.ids, usb.ids
303
304 * Thu Sep 20 2007 Karsten Hopp <karsten@redhat.com> 0.210-1
305 - add pci.id for Chelsio 10GbE Ethernet Adapter
306 - Resolves: bz #296811
307
308 * Wed Sep 19 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
309 - pull new upstream pci.ids, usb.ids
310
311 * Wed Aug 29 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
312 - update license tag
313
314 * Wed Aug 15 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
315 - pull new upstream pci.ids and rebuild
316 - Resolves: bz #251732
317 - Resolves: bz #251734
318 - Resolves: bz #252195
319 - Resolves: bz #252196
320 - Resolves: bz #241274
321
322 * Tue Aug 14 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
323 - add HP TFT5600        #229370
324
325 * Mon Jul 09 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
326 - enable iwl4965 blacklist
327 - Resolves: bz#245379
328
329 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
330 - really update pci.ids, update-pciids downloaded an old file
331 - disable iwl4965 blacklist as it is not approved yet (#245379)
332
333 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.202-1
334 - don't load iwl4965 module automatically
335 - Resolves: #245379
336
337 * Tue Jun 19 2007 Karsten Hopp <karsten@redhat.com> 0.201-1
338 - add some monitors
339 - Resolves: #224511
340 - update pci.ids
341 - Related: #223105
342
343 * Tue Jan 02 2007 Karsten Hopp <karsten@redhat.com> 0.194-1
344 - Update to latest pci.ids/usb.ids for RHEL5
345 - Resolves: #220182
346   Add some Dell monitors to MonitorDB
347
348 * Mon Oct 09 2006 Phil Knirsch <pknirsch@redhat.com> - 0.191-1
349 - Update to latest pci.ids for RHEL5
350
351 * Thu Sep 21 2006 Adam Jackson <ajackson@redhat.com> - 0.190-1
352 - Add a description for the 'intel' driver.
353
354 * Mon Sep 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.189-1
355 - Updated usb.ids for FC6
356
357 * Mon Sep 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.188-1
358 - Update of pci.ids for FC6
359
360 * Thu Aug 31 2006 Adam Jackson <ajackson@redhat.com> - 0.187-1
361 - Fix sync ranges for Samsung SyncMaster 710N (#202344)
362
363 * Thu Aug 03 2006 Phil Knirsch <pknirsch@redhat.com> - 0.186-1
364 - Updated pci.ids once more.
365
366 * Tue Jul 25 2006 Phil Knirsch <pknirsch@redhat.com> - 0.185-1
367 - Added the 17inch Philips LCD monitor entry (#199828)
368
369 * Mon Jul 24 2006 Phil Knirsch <pknirsch@redhat.com> - 0.184-1
370 - Added one more entry for missing Philips LCD monitor (#199828)
371
372 * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.183-1
373 - Updated pci.ids before FC6 final (#198994)
374 - Added several missing Samsung monitors (#197463)
375 - Included a new inf2mondb.py from Matt Domsch (#158723)
376
377 * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> - 0.182-1
378 - Added ast driver description to videodrivers
379 - Numerous Dell monitor additions (#196734)
380 - Numerous Belinea monitor additions (#198087)
381
382 * Sat Jul  8 2006 Adam Jackson <ajackson@redhat.com> - 0.181-1
383 - Updated videodrivers to mention i945
384 - New monitors: Sony CPD-G420 (#145902), Compaq P1110 (#155120).
385
386 * Thu May 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.180-1
387 - Updated and added some MonitorsDB entries
388
389 * Tue May 02 2006 Phil Knirsch <pknirsch@redhat.com> - 0.179-1
390 - Updated PCI ids from upstream (#180402)
391 - Fixed missing monitor entry in MonitorsDB (#189446)
392
393 * Wed Mar 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.178-1
394 - Commented out the VT lines at the end of usb.ids as our tools don't handle
395   them properly.
396
397 * Fri Feb 24 2006 Bill Nottingham <notting@redhat.com> - 0.177-1
398 - remove stock videoaliases in favor of driver-specific ones in
399   the X driver packages
400
401 * Wed Feb 22 2006 Phil Knirsch <pknirsch@redhat.com> - 0.176-1
402 - More entries from Dell to MonitorsDB (#181008)
403
404 * Fri Feb 10 2006 Phil Knirsch <pknirsch@redhat.com> - 0.175-1
405 - Added a few more entries to MonitorsDB
406
407 * Wed Feb 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.174-1
408 - Some cleanup and adds to the MonitorDB which closes several db related bugs.
409
410 * Tue Dec 13 2005 Bill Nottingham <notting@redhat.com> - 0.173-1
411 - add some IDs to the generic display entries for matching laptops
412
413 * Fri Nov 18 2005 Bill Nottingham <notting@redhat.com> - 0.172-1
414 - ditto for radeon
415
416 * Fri Nov 18 2005 Jeremy Katz <katzj@redhat.com> - 0.171-1
417 - r128 -> ati.  should fix the unresolved symbol and kem says its more 
418   generally the "right" thing to do
419
420 * Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 0.170-1
421 - handle mptsas for migration as well
422 - move videoaliases file to a subdir
423
424 * Fri Sep 16 2005 Bill Nottingham <notting@redhat.com>
425 - add Iiyama monitor (#168143)
426
427 * Tue Sep 13 2005 Bill Nottingham <notting@redhat.com>
428 - add IBM monitor (#168080)
429
430 * Thu Sep  8 2005 Bill Nottingham <notting@redhat.com> - 0.169-1
431 - remove Cards, pcitable. Add videodrivers
432
433 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.168-1
434 - Add more Gateway monitors
435
436 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.167-1
437 - Add some ADI monitors, one BenQ, and and DPMS codes for two Apples
438
439 * Fri Sep  2 2005 Bill Nottingham <notting@redhat.com> - 0.166-1
440 - add videoaliases file
441 - remove CardMonitorCombos, as nothing uses it
442
443 * Thu Aug 25 2005 Dan Williams <dcbw@redhat.com> - 0.165-1
444 - Add a bunch of Acer monitors
445
446 * Tue Aug  9 2005 Jeremy Katz <katzj@redhat.com> - 0.164-1
447 - migrate sk98lin -> skge
448
449 * Sat Jul 30 2005 Bill Nottingham <notting@redhat.com>
450 - migrate mpt module names (#161420)
451 - remove pcitable entries for drivers in modules.pcimap
452 - switch lone remaining 'Server' entry - that can't work right
453
454 * Tue Jul 26 2005 Bill Nottingham <notting@redhat.com>
455 - add Daytek monitor (#164339)
456
457 * Wed Jul 13 2005 Bill Nottingham <notting@redhat.com> - 0.162-1
458 - remove /etc/pcmcia/config, conflict with pcmcia-cs
459
460 * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> - 0.160-1
461 - move blacklist to /etc/modprobe.d, require new module-init-tools
462 - add LG monitors (#162466, #161734)
463 - add orinoco card (#161696)
464 - more mptfusion stuff (#107088)
465
466 * Thu Jun 23 2005 Bill Nottingham <notting@redhat.com>
467 - add Samsung monitor (#161013)
468
469 * Wed Jun 22 2005 Bill Nottingham <notting@redhat.com> - 0.159-1
470 - pcitable: make branding happy (#160047)
471 - Cards: add required blank line (#157972)
472 - add some monitors
473 - add JVC CD-ROM (#160907, <richard@rsk.demon.co.uk>)
474 - add hisax stuff to blacklist (#154799, #159068)
475
476 * Mon May 16 2005 Bill Nottingham <notting@redhat.com> - 0.158-1
477 - add a orinoco card (#157482)
478
479 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 0.157-1
480 - add 20" Apple Cinema Display
481
482 * Sun Apr 10 2005 Mike A. Harris <mharris@redhat.com> 0.156-1
483 - Update SiS entries in Cards/pcitable to match what Xorg X11 6.8.2 supports
484
485 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.155-1
486 - Add a boatload of BenQ, Acer, Sony, NEC, Mitsubishi, and Dell monitors
487
488 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.154-1
489 - Add Typhoon Speednet Wireless PCMCIA Card mapping to atmel_cs driver
490
491 * Mon Mar 28 2005 Bill Nottingham <notting@redhat.com> 0.153-1
492 - update the framebuffer blacklist
493
494 * Wed Mar  9 2005 Bill Nottingham <notting@redhat.com> 0.152-1
495 - fix qlogic driver mappings, add upgradelist mappings for the modules
496   that changed names (#150621)
497
498 * Wed Mar  2 2005 Mike A. Harris <mharris@redhat.com> 0.151-1
499 - Added one hundred billion new nvidia PCI IDs to pcitable and Cards to
500   synchronize it with X.Org X11 6.8.2.  (#140601)
501
502 * Tue Jan 11 2005 Dan Williams <dcbw@redhat.com> - 0.150-1
503 - Add Dell UltraSharp 1704FPV (Analog & Digital)
504
505 * Sun Nov 21 2004 Bill Nottingham <notting@redhat.com> - 0.148-1
506 - add Amptron monitors (#139142)
507
508 * Wed Nov 10 2004 Bill Nottingham <notting@redhat.com> - 0.147-1
509 - update usb.ids (#138533)
510 - migrate dpt_i2o to i2o_block (#138603)
511
512 * Tue Nov  9 2004 Bill Nottingham <notting@redhat.com> - 0.146-1
513 - update pci.ids (#138233)
514 - add Apple monitors (#138481)
515
516 * Wed Oct 20 2004 Bill Nottingham <notting@redhat.com> - 0.145-1
517 - remove ahci mappings, don't prefer it over ata_piix
518
519 * Tue Oct 19 2004 Kristian Høgsberg <krh@redhat.com> - 0.144-1
520 - update IDs for Cirrus, Trident, C&T, and S3
521
522 * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> - 0.143-1
523 - add ahci mappings to prefer it over ata_piix
524 - map davej's ancient matrox card to vesa (#122750)
525
526 * Thu Oct  7 2004 Dan Williams <dcbw@redhat.com> - 0.141-1
527 - Add Belkin F5D6020 ver.2 (802.11b card based on Atmel chipset)
528
529 * Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> - 0.140-1
530 - include /etc/hotplug/blacklist here
531
532 * Thu Sep 30 2004 Bill Nottingham <notting@redhat.com> - 0.136-1
533 - add S3 UniChrome (#131403)
534 - update pci.ids
535
536 * Thu Sep 23 2004 Bill Nottingham <notting@redhat.com> - 0.135-1
537 - megaraid -> megaraid_mbox
538
539 * Wed Sep 22 2004 Bill Nottingham <notting@redhat.com> - 0.134-1
540 - map ncr53c8xx to sym53c8xx (#133181)
541
542 * Fri Sep 17 2004 Bill Nottingham <notting@redhat.com> - 0.132-1
543 - fix 3Ware 9000 mapping (#132851)
544
545 * Tue Sep 14 2004 Kristian Høgsberg <krh@redhat.com> - 0.131-1
546 - Add python script to check sorting of pci.ids
547
548 * Thu Sep  9 2004 Kristian Høgsberg <krh@redhat.com> 0.131-1
549 - Add pci ids and cards for new ATI, NVIDIA and Intel cards
550
551 * Sat Sep  4 2004 Bill Nottingham <notting@redhat.com> 0.130-1
552 - trim pcitable - now just ids/drivers
553
554 * Wed Sep  1 2004 Bill Nottingham <notting@redhat.com> 0.125-1
555 - pci.ids updates
556 - remove updsftab.conf.*
557
558 * Sun Aug 29 2004 Mike A. Harris <mharris@redhat.com>  0.124-1
559 - Updates to pcitable/Cards for 'S3 Trio64 3D' cards. (#125866,59956)
560
561 * Fri Jul  9 2004 Mike A. Harris <mharris@redhat.com>  0.123-1
562 - Quick pcitable/Cards update for ATI Radeon and FireGL boards
563
564 * Mon Jun 28 2004 Bill Nottingham <notting@redhat.com>
565 - add Proview monitor (#125853)
566 - add ViewSonic monitor (#126324)
567 - add a Concord camera (#126673)
568
569 * Wed Jun 23 2004 Brent Fox <bfox@redhat.com> - 0.122-1
570 - Add Vobis monitor to MonitorsDB (bug #124151)
571
572 * Wed Jun 09 2004 Dan Williams <dcbw@redhat.com> - 0.121-1
573 - add Belkin F5D5020 10/100 PCMCIA card (#125581)
574
575 * Fri May 28 2004 Bill Nottingham <notting@redhat.com>
576 - add modem (#124663)
577
578 * Mon May 24 2004 Bill Nottingham <notting@redhat.com> - 0.120-1
579 - mainly:
580   fix upgradelist module for CMPci cards (#123647)
581 - also:
582   add another wireless card (#122676)
583   add wireless card (#122625)
584   add 1280x800 (#121548)
585   add 1680x1050 (#121148)
586   add IntelligentStick (#124313)
587
588 * Mon May 10 2004 Jeremy Katz <katzj@redhat.com> - 0.119-1
589 - veth driver is iseries_veth in 2.6
590
591 * Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 0.118-1
592 - add a wireless card (#122064)
593 - and a monitor (#121696)
594
595 * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.117-1
596 - fix makefile
597
598 * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 0.116-1
599 - move updfstab.conf here
600 - add wireless card (#116865)
601 - add laptop display panel (#117385)
602 - add clipdrive (#119928)
603 - add travelling disk (#119143)
604 - add NEXDISK (#106782)
605
606 * Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 0.115-1
607 - replace snd-es1960 driver with snd-es1968 in pcitable (bug #120729)
608
609 * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 0.114-1
610 - fix entries pointing to Banshee (#119388)
611
612 * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.113-1
613 - add a Marvell sk98lin card (#118467, <64bit_fedora@comcast.net>)
614
615 * Fri Mar 12 2004 Brent Fox <bfox@redhat.com> 0.112-1
616 - add a Sun flat panel to MonitorsDB (bug #118138)
617
618 * Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 0.111-1
619 - add Samsung monitor to MonitorsDB (bug #112112)
620
621 * Mon Mar  1 2004 Mike A. Harris <mharris@redhat.com> 0.110-1
622 - Added 3Dfx Voodoo Graphics and Voodoo II entries to the Cards database, both
623   pointing to Alan Cox's new "voodoo" driver which is now included in XFree86
624   4.3.0-62 and later builds in Fedora development.  Mapped their PCI IDs to
625   the new Cards entry in pcitable.
626 - Updated the entries for 3Dfx Banshee
627
628 * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 0.109-1
629 - pci.ids and other updates
630
631 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.108-1
632 - Added Shamrock C407L to MonitorsDB for bug (#104920)
633
634 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.107-1
635 - Massive Viewsonic monitor update for MonitorsDB (#84882)
636
637 * Fri Feb 13 2004 John Dennis <jdennis@finch.boston.redhat.com> 0.106-1
638 - fix typo, GP should have been HP
639
640 * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 0.105-1
641 - many monitor updates (#114260, #114216, #113993, #113932, #113782,
642   #113685, #113523, #111203, #107788, #106526, #63005)
643 - add some PCMCIA cards (#113006, #112505)
644
645 * Tue Jan 20 2004 Bill Nottingham <notting@redhat.com> 0.104-1
646 - switch sound module mappings to alsa drivers
647
648 * Mon Jan 19 2004 Brent Fox <bfox@redhat.com> 0.103-1
649 - fix tab spacing
650
651 * Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.102-1
652 - added an entry for ATI Radeon 9200SE (bug #111306)
653
654 * Sun Oct 26 2003 Jeremy Katz <katzj@redhat.com> 0.101-1
655 - add 1920x1200 Generic LCD as used on some Dell laptops (#108006)
656
657 * Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.100-1
658 - add entry for Sun (made by Samsung) monitor (bug #107128)
659
660 * Tue Sep 23 2003 Mike A. Harris <mharris@redhat.com> 0.99-1
661 - Added entries for Radeon 9600/9600Pro/9800Pro to Cards
662 - Fixed minor glitch in pcitable for Radeon 9500 Pro
663
664 * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
665 - add VMWare display adapter pci id and map to vmware X driver
666
667 * Thu Sep 11 2003 Bill Nottingham <notting@redhat.com> 0.97-1
668 - bcm4400 -> b44
669
670 * Sun Sep  7 2003 Bill Nottingham <notting@redhat.com> 0.96-1
671 - fix provided Dell tweaks (#103892)
672
673 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.95-1
674 - Dell tweaks (#103861)
675
676 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.94-1
677 - add adaptec pci id (#100844)
678
679 * Thu Sep  4 2003 Brent Fox <bfox@redhat.com> 0.93-1
680 - add an SGI monitor for bug (#74870)
681
682 * Wed Aug 27 2003 Bill Nottingham <notting@redhat.com> 0.92-1
683 - updates from sourceforge.net pci.ids, update pcitable accordingly
684
685 * Mon Aug 18 2003 Mike A. Harris <mharris@redhat.com> 0.91-1
686 - Added HP monitors for bug (#102495)
687
688 * Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 0.90-1
689 - added a sony monitor (bug #101550)
690
691 * Tue Jul 15 2003 Bill Nottingham <notting@redhat.com> 0.89-1
692 - updates from modules.pcimap
693
694 * Sat Jul 12 2003 Mike A. Harris <mharris@redhat.com> 0.88-1
695 - Update MonitorsDB for new IBM monitors from upstream XFree86 bugzilla:
696   http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=459
697
698 * Mon Jun  9 2003 Bill Nottingham <notting@redhat.com> 0.87-1
699 - fusion update
700
701 * Mon Jun  9 2003 Jeremy Katz <katzj@redhat.com> 0.86-1
702 - pci id for ata_piix
703
704 * Wed Jun  4 2003 Brent Fox <bfox@redhat.com> 0.85-1
705 - correct entry for Dell P991 monitor
706
707 * Tue Jun  3 2003 Bill Nottingham <notting@redhat.com> 0.84-1
708 - fix qla2100 mapping (#91476)
709 - add dell mappings (#84069)
710
711 * Mon Jun  2 2003 John Dennis <jdennis@redhat.com>
712 - Add new Compaq and HP monitors - bug 90570, bug 90707, bug 90575, IT 17231
713
714 * Wed May 21 2003 Brent Fox <bfox@redhat.com> 0.81-1
715 - add an entry for SiS 650 video card (bug #88271)
716
717 * Wed May 21 2003 Michael Fulbright <msf@redhat.com> 0.80-1
718 - Changed Generic monitor entries in MonitorsDB to being in LCD and CRT groups
719
720 * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 0.79-1
721 - pci.ids and usb.ids updates
722
723 * Tue May  6 2003 Brent Fox <bfox@redhat.com> 0.78-1
724 - added a Samsung monitor to MonitorsDB
725
726 * Fri May  2 2003 Bill Nottingham <notting@redhat.com>
727 - add Xircom wireless airo_cs card (#90099)
728
729 * Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.77-1
730 - add generic framebuffer to Cards
731
732 * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 0.76-1
733 - Updated MonitorsDb for Dell monitors (#86072)
734
735 * Tue Feb 18 2003 Mike A. Harris <mharris@redhat.com> 0.75-1
736 - Change savage MX and IX driver default back to "savage" for the 1.1.27t
737   driver update
738   
739 * Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 0.74-1
740 - Use full resolution description for Dell laptop screens (bug #80398)
741
742 * Thu Feb 13 2003 Mike A. Harris <mharris@redhat.com> 0.73-1
743 - Updated pcitable and Cards database to fix Savage entries up a bit, and
744   change default Savage/MX driver to 'vesa' as it is hosed and with no sign
745   of working in time for 4.3.0.  Fixes (#72476,80278,80346,80423,82394)
746
747 * Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.72-1
748 - slightly alter the sync rates for the Dell 1503FP (bug #84123)
749
750 * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 0.71-1
751 - large pcitable and pci.ids updates
752 - more tg3, e100
753
754 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.69-1
755 - Updated pcitable and Cards database for new Intel i852/i855/i865 support
756
757 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.68-1
758 - Massive update of all ATI video hardware PCI IDs in pcitable and a fair
759   number of additions and corrections to the Cards database as well
760   
761 * Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 0.67-1
762 - change refresh rates of sny0000 monitors to use a low common denominator
763
764 * Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 0.66-1
765 - don't force DRI off on R200 (#82957)
766
767 * Fri Jan 24 2003 Mike A. Harris <mharris@redhat.com> 0.65-1
768 - Added Card:S3 Trio64V2 (Unsupported RAMDAC) entry to pcitable, pci.ids, and
769   Cards database to default this particular variant to "vesa" driver (#81659)
770
771 * Thu Jan  2 2003 Bill Nottingham <notting@redhat.com> 0.64-1
772 - pci.ids and associated pcitable updates
773
774 * Sun Dec 29 2002 Mike A. Harris <mharris@redhat.com> 0.63-1
775 - Updates for GeForce 2 Go, GeForce 4 (#80209)
776
777 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-2
778 - fix Cards for NatSemi Geode
779
780 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-1
781 - use e100 instead of eepro100 for pcmcia
782
783 * Mon Nov 25 2002 Mike A. Harris <mharris@redhat.com>
784 - Complete reconstruction of all Neomagic hardware entries in Cards
785   database to reflect current XFree86, as well as pcitable update,
786   and submitted cleaned up entries to sourceforge
787
788 * Mon Nov  4 2002 Bill Nottingham <notting@redhat.com> 0.61-1
789 - move pcmcia config file here
790 - sort MonitorsDB, add some entries, remove dups
791 - switch some network driver mappings
792
793 * Tue Sep 24 2002 Bill Nottingham <notting@redhat.com> 0.48-1
794 - broadcom 5704 mapping
795 - aic79xx (#73781)
796
797 * Thu Sep  5 2002 Bill Nottingham <notting@redhat.com> 0.47-1
798 - pci.ids updates
799 - add msw's wireless card
800
801 * Tue Sep  3 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
802 - Card entries in pcitable need matching in Cards
803
804 * Sun Sep  1 2002 Mike A. Harris <mharris@redhat.com> 0.45-1
805 - Update G450 entry in Cards
806
807 * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 0.44-1
808 - fix some of the Dell entries
809 - add cardbus controller id (#71198)
810 - add audigy mapping
811 - add NEC monitor (#71320)
812
813 * Tue Aug 13 2002 Preston Brown <pbrown@redhat.com> 0.43-1
814 - pci.id for SMC wireless PCI card (#67346)
815
816 * Sat Aug 10 2002 Mike A. Harris <mharris@redhat.com> 0.42-1
817 - Change default driver for old S3 based "Miro" card for bug (#70743)
818
819 * Fri Aug  9 2002 Preston Brown <pbrown@redhat.com> 0.41-1
820 - fix tabs in pci.ids
821 - Change pci ids for the PowerEdge 4 series again...
822
823 * Tue Aug  6 2002 Preston Brown <pbrown@redhat.com> 0.39-1
824 - Dell PERC and SCSI pci.id additions
825
826 * Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 0.38-1
827 - Removed and/or invalid entries from Cards database BLOCKER (#70802)
828
829 * Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 0.37-1
830 - Changed Matrox G450 driver default options to fix bug (#66697)
831 - Corrected S3 Trio64V2 bug in Cards file (#66492)
832
833 * Tue Jul 30 2002 Bill Nottingham <notting@redhat.com> 0.36-1
834 - tweaks for Dell Remote Assisstant cards (#60376)
835
836 * Fri Jul 26 2002 Mike A. Harris <mharris@redhat.com> 0.35-1
837 - Updated Cards db for CT69000
838 - Various ATI cleanups and additions to Cards and pcitable
839 - Updated S3 Trio3D to default to "vesa" driver (#59956)
840
841 * Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.33-1
842 - Eizo monitor updates (#56080, <triad@df.lth.se>)
843 - pci.ids updates, corresponding pcitable updates
844 - pcilint for pcitable 
845
846 * Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 0.32-1
847 - switch de4x5 back to tulip
848
849 * Mon Jun 24 2002 Mike A. Harris <mharris@redhat.com> 0.31-1
850 - Modified ATI entries in pcitable to be able to autodetect the FireGL 8700
851   and FireGL 8800 which both have the same ID, but different subdevice ID's.
852   Added entries to Cards database for the 8700/8800 as well.
853
854 * Tue May 28 2002 Mike A. Harris <mharris@redhat.com> 0.30-1
855 - Reconfigured Cards database to default to XFree86 4.x for ALL video
856   hardware, since 3.3.6 support is being removed.  Video cards not
857   supported natively by 4.x will be changed to use the vesa or vga
858   driver, or completely removed as unsupported.
859
860 * Wed Apr 17 2002 Michael Fulbright <msf@redhat.com> 0.14-1
861 - another megaraid variant
862
863 * Mon Apr 15 2002 Michael Fulbright <msf@redhat.com> 0.13-1
864 - fix monitor entry for Dell 1600X Laptop Display Panel
865
866 * Fri Apr 12 2002 Bill Nottingham <notting@redhat.com> 0.13-1
867 - more aacraid
868
869 * Tue Apr  9 2002 Bill Nottingham <notting@redhat.com> 0.12-1
870 - another 3ware, another megaraid
871
872 * Fri Apr  5 2002 Mike A. Harris <mharris@redhat.com> 0.11-1
873 - Added commented out line for some Radeon 7500 cards to Cards database.
874
875 * Tue Apr  2 2002 Mike A. Harris <mharris@redhat.com> 0.10-1
876 - Fixed i830 entry to use driver "i810" not "i830" which doesn't exist
877
878 * Mon Apr  1 2002 Bill Nottingham <notting@redhat.com> 0.9-1
879 - fix rebuild (#62459)
880 - SuperSavage ids (#62101)
881 - updates from pci.ids
882
883 * Mon Mar 18 2002 Bill Nottingham <notting@redhat.com> 0.8-2
884 - fix errant space (#61363)
885
886 * Thu Mar 14 2002 Bill Nottingham <notting@redhat.com> 0.8-1
887 - nVidia updates
888
889 * Wed Mar 13 2002 Bill Nottingham <notting@redhat.com> 0.7-1
890 - lots of pcitable updates
891
892 * Tue Mar  5 2002 Mike A. Harris <mharris@redhat.com> 0.6-1
893 - Updated Cards database
894
895 * Mon Mar  4 2002 Mike A. Harris <mharris@redhat.com> 0.5-1
896 - Built new package with updated database files for rawhide.
897
898 * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 0.3-1
899 - return of XFree86-3.3.x
900
901 * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 0.1-1
902 - initial build