- Github migration related changes
[oweals/hwdata.git] / hwdata.spec
1 # This package is arch-specific just because of bundling different files for
2 # different architectures. No -debuginfo package is needed.
3 %global     debug_package %{nil}
4 %global     uprelease   8.5
5
6 Name:       hwdata
7 Summary:    Hardware identification and configuration data
8 Version:    0.252
9 Release:    %{uprelease}%{?dist}
10 License:    GPLv2+
11 Group:      System Environment/Base
12 Source:     https://github.com/vcrhonek/hwdata/archive/v%{version}-%{?uprelease}.tar.gz
13 URL:        https://github.com/vcrhonek/hwdata
14
15 BuildRequires   : perl
16 BuildRequires   : perl(Date::Format)
17
18 Requires        : systemd
19 Requires(post)  : systemd
20 Requires(postun): systemd
21
22 %description
23 hwdata contains various hardware identification and configuration data,
24 such as the pci.ids and usb.ids databases.
25
26 %prep
27 %setup -q -n %{name}-%{version}-%{uprelease}
28 %configure
29
30 %build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_prefix}/lib
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %post
40 udevadm hwdb --update >/dev/null 2>&1 || :
41
42 %postun
43 udevadm hwdb --update >/dev/null 2>&1 || :
44
45 %files
46 %doc LICENSE COPYING
47 %dir %{_datadir}/%{name}
48 %{_prefix}/lib/modprobe.d/dist-blacklist.conf
49 %{_prefix}/lib/udev/hwdb.d/[0-9][0-9]-*.hwdb
50 %{_datadir}/%{name}/*
51
52 %changelog
53 * Mon Mar 20 2017 Vitezslav Crhonek <vcrhonek@redhat.com> - 0.252-8.5
54 - Updated pci, usb and vendor ids
55   Resolves: #1386133 #1424763
56 - Removed module nx_crypto from blacklist on PowerPCs
57   Resolves: #1264326
58
59 * Thu Sep 29 2016 Vitezslav Crhonek <vcrhonek@redhat.com> - 0.252-8.4
60 - Remove wrong entry from usb ids.
61   Resolves: #1380159
62
63 * Mon Sep 26 2016 Vitezslav Crhonek <vcrhonek@redhat.com> - 0.252-8.3
64 - Updated pci, usb and vendor ids.
65 - Resolves: rhbz#1292382
66
67 * Tue Jun 28 2016 Michal Minar <miminar@redhat.com> 0.252-8.2
68 - Updated pci, usb and vendor ids.
69 - Resolves: rhbz#1292382
70 - Resolves: rhbz#1291614
71 - Resolves: rhbz#1324198
72
73 * Fri Oct 23 2015 Michal Minar <miminar@redhat.com> 0.252-8.1
74 - Updated pci, usb and vendor ids.
75 - Resolves: rhbz#1236458
76 - Resolves: rhbz#1256004
77 - Resolves: rhbz#1266217
78 - Resolves: rhbz#1271797
79
80 * Mon Jun 29 2015 Michal Minar <miminar@redhat.com> 0.252-7.9
81 - Updated pci, usb and vendor ids.
82
83 * Tue Apr 14 2015 Michal Minar <miminar@redhat.com> 0.252-7.8
84 - Blacklisted module nx_crypto on PowerPCs.
85 - Resolves: rhbz#1211389
86 - Disable debuginfo build.
87
88 * Fri Apr 10 2015 Michal Minar <miminar@redhat.com> 0.252-7.6
89 - Blacklisted experimental module sha1-mb.
90 - Resolves: rhbz#1208120
91
92 * Fri Jan 30 2015 Michal Minar <miminar@redhat.com> 0.252-7.5
93 - Updated vendor, usb and pci ids.
94
95 * Mon Sep 22 2014 Michal Minar <miminar@redhat.com> 0.252-7.4
96 - Updated vendor, usb and pci ids.
97
98 * Thu Mar 27 2014 Michal Minar <miminar@redhat.com> 0.252-7.3
99 - Added few more hwdb files.
100 - Updated vendor and pci ids.
101
102 * Thu Mar 20 2014 Michal Minar <miminar@redhat.com> 0.252-7.1
103 - Bumped release to reflect rhel version.
104 - Fixed bogus dates in changelog.
105 - Generate and install hwdb.d/* files.
106
107 * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.252-3
108 - Mass rebuild 2013-12-27
109
110 * Mon Aug 5 2013 Michal Minar <miminar@redhat.com> 0.252-2
111 - Changelog fix.
112
113 * Sun Jul 21 2013 Michal Minar <miminar@redhat.com> 0.252-1
114 - Data files update.
115
116 * Sat Jul 06 2013 Michal Minar <miminar@redhat.com> 0.250-1
117 - Data files update.
118
119 * Thu Jun 20 2013 Michal Minar <miminar@redhat.com> 0.249-1
120 - Data files update, pnp.ids included.
121
122 * Thu Apr 18 2013 Michal Minar <miminar@redhat.com> 0.248-1
123 - Data files update
124
125 * Wed Mar 27 2013 Michal Minar <miminar@redhat.com> 0.247-1
126 - Moved blacklist.conf from /etc/modprobe.d to /usr/lib/modprobe.d.
127 - Renamed it to dist-blacklist.conf.
128 - Data files update
129
130 * Mon Mar 18 2013 Michal Minar <miminar@redhat.com> 0.245-1
131 - Data files update
132
133 * Mon Feb 18 2013 Michal Minar <miminar@redhat.com> 0.244-1
134 - Data files updated
135
136 * Fri Jan 18 2013 Michal Minar <miminar@redhat.com> 0.243-1
137 - Data files updated
138
139 * Fri Dec 07 2012 Michal Minar <miminar@redhat.com> 0.242-1
140 - Update data files
141
142 * Wed Nov 07 2012 Michal Minar <miminar@redhat.com> 0.241-1
143 - Update data files
144
145 * Wed Sep 26 2012 Michal Minar <miminar@redhat.com> 0.240-1
146 - made use of configure script in prep
147
148 * Tue Sep 25 2012 Michal Minar <miminar@redhat.com> 0.239-1
149 - Update data files
150
151 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.238-1
152 - Fix reference specfile to current Fedora style
153
154 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.235-1
155 - Update data files
156 - Remove upgradelist, not needed since kudzu-ectomy
157
158 * Mon Aug 08 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.3
159 - update pci.ids, usb. ids
160
161 * Mon May 02 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.2
162 - update pci.ids with a fix for QLogic Infiniband adapter
163
164 * Wed Apr 27 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.1
165 - update to latest pci.ids, usb.ids
166
167 * Fri Jan 28 2011 Karsten Hopp <karsten@redhat.com> 0.233-7
168 - bump release
169 - update oui.txt URL
170 - fix tarball name in spec file
171 - update usb.ids, out.txt and pci.ids
172
173 * Wed Aug 25 2010 Karsten Hopp <karsten@redhat.com> 0.233-1
174 - update usb.ids, out.txt and pci.ids
175
176 * Thu Aug 05 2010 Karsten Hopp <karsten@redhat.com> 0.232-1
177 - update usb.ids, out.txt and pci.ids (#550020, #611860)
178 - fix incorrect syntax doc/comment in blacklist.conf (Ville Skyttä, #532802)
179 - add Acer B243HL and BenQ G2420HDBL (Ville Skyttä, #590787)
180 - add HP LP2475w and Samsung 2494HM (Ville Skyttä, #595059)
181
182 * Tue May 25 2010 Phil Knirsch <pknirsch@redhat.com> 0.230-1
183 - update usb.ids, out.txt and pci.ids
184 - Resolves: #584788
185
186 * Mon Mar 29 2010 Karsten Hopp <karsten@redhat.com> 0.229-1
187 - update usb.ids, out.txt and pci.ids for F-13 (#571914)
188
189 * Wed Mar 17 2010 Phil Knirsch <pknirsch@redhat.com> 0.228-1
190 - Blacklist chsc_sch for s390x
191 - Resolves: #563228
192
193 * Tue Feb 23 2010 Dave Airlie <airlied@redhat.com> 0.227-1
194 - add viafb to blacklist
195
196 * Mon Feb 22 2010 Karsten Hopp <karsten@redhat.com> 0.227-1
197 - update usb.ids, pci.ids, oui.txt
198 - update license
199
200 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.226-1
201 - update release number
202
203 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.225-4
204 - update usb.ids pci.ids oui.txt
205
206 * Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0.225-3.1
207 - Rebuilt for RHEL 6
208
209 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.225-3
210 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
211
212 * Tue Jul 07 2009 Adam Jackson <ajax@redhat.com> 0.225-2
213 - pnp-dell.patch: Fix Dell's entry in pnp.ids
214
215 * Thu Apr 09 2009 Adam Jackson <ajax@redhat.com> 0.224-1
216 - Update pci.ids, usb.ids, and oui.txt
217 - Add pnp.ids
218
219 * Thu Mar 19 2009 Karsten Hopp <karsten@redhat.com> 0.223-1
220 - update usb.ids pci.ids oui.txt
221 - rename /etc/modprobe.d/blacklist to /etc/modprobe.d/blacklist.conf
222
223 * Wed Jan 28 2009 Karsten Hopp <karsten@redhat.com> 0.222-1
224 - update usb.ids pci.ids oui.txt and build for all current releases
225   Fixes p.e. #465440
226
227 * Wed Jan 21 2009 Karsten Hopp <karsten@redhat.com> 0.221-1
228 - update usb.ids pci.ids oui.txt
229
230 * Tue Dec 02 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
231 - add new monitor entries from Mandriva hardware database (Thierry Vignaud)
232 - make generic entries have properly formated frequencies (Thierry Vignaud)
233 - remove duplicate Dell monitor entries (Thierry Vignaud)
234 - more vendor name fixes
235 - fix extra field in 'Compudyne KD-1500N' definition (Thierry Vignaud)
236 - make Dell monitors case consistent (Thierry Vignaud)
237 - make all GoldStar monitors have the same vendor name (Thierry Vignaud)
238 - add URL of git repository
239 - fix spacing (Thierry Vignaud)
240 - sort MonitorDB file with LANG=C sort -f -t ";" -k1,2
241 - add Samsung SyncMaster 2443BWX (Marc van den Dikkenberg)
242 - add some Lenovo monitors (Im Sza)
243
244 * Wed Jul 23 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
245 - update pci.ids, usb.ids, oui.txt
246 - MonitorsDB: add some Samsung monitors (Ronald Warsow)
247 - MonitorsDB: add Dell E1609W (Matt Domsch)
248 - MonitorsDB: add 7 Dell monitors (Matt Domsch)
249 - MonitorsDB: add a bunch of Hyundai and ImageQuest monitors
250
251 * Mon Jun 09 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
252 - add BenQ FP2091 monitor (Peter Williams)
253 - add a bunch of Hyundai and ImageQuest monitors
254
255 * Mon Jun 02 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
256 - update pci.ids, usb.ids, oui.txt
257 - blacklist snd-pcsp (#448425)
258
259 * Mon May 19 2008 Karsten Hopp <karsten@redhat.com> 0.218-1
260 - add some Acer monitors (Im Sz)
261
262 * Tue Apr 01 2008 Karsten Hopp <karsten@redhat.com> 0.217-1
263 - update pci.ids, oui.txt
264 - update usb.ids, fixes #439963
265 - add HP w1907 LCD monitor, fixes #431359
266 - fix many monitor entries (Stanislav Ievlev, #430276)
267
268
269 * Mon Mar 03 2008 Karsten Hopp <karsten@redhat.com> 0.216-1
270 - update pci.ids, usb.ids (#431658)
271
272 * Tue Jan 29 2008 Phil Knirsch <pknirsch@redhat.com> 0.215-1
273 - Pull new upstream pci.ids
274
275 * Wed Jan 23 2008 Karsten Hopp <karsten@redhat.com> 0.215-1
276 - add HP W2207 monitor
277 - add oui.txt, a list of bluetooth device makers
278
279 * Fri Jan 18 2008 Karsten Hopp <karsten@redhat.com> 0.214-1
280 - remove MonitorsDB.generic as it isn't used anywhere
281 - drop RHEL-5 blacklist patch in -devel
282
283 * Tue Jan 15 2008 Karsten Hopp <karsten@redhat.com> 0.213-1
284 - add many monitor entries (Im Sza, #367111)
285
286 * Fri Jan 11 2008 Karsten Hopp <karsten@redhat.com> 0.212-1
287 - pull new upstream pci.ids, usb.ids
288 - Resolves: #300831
289 - added HP TFT5600 LCD Monitor
290 - Resolves: #250569
291 - added Acer AL1916W, Eizo L568/L568D, Samsung 795DF
292 - Resolves: #250582
293 - Add Samsung 205BW/206BW/225BW/226BW
294 - Resolves: #250584
295 - Add Samsung 931BF
296 - Resolves: #250587
297
298 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
299 - add Proview 926w monitor (#363091)
300
301 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.208-1
302 - new release
303 - drop dell-monitors patch, already included in tarball
304
305 * Thu Dec 13 2007 Karsten Hopp <karsten@redhat.com> 0.207-3
306 - fix License tag
307 - add empty %%build section for fedora-review
308
309 * Thu Oct 25 2007 Matt Domsch <Matt_Domsch@dell.com> 0.207-2
310 - MonitorsDB: add 20 new Dell monitors
311
312 * Wed Sep 26 2007 Karsten Hopp <karsten@redhat.com> 0.211-1
313 - pull new upstream pci.ids, usb.ids
314
315 * Thu Sep 20 2007 Karsten Hopp <karsten@redhat.com> 0.210-1
316 - add pci.id for Chelsio 10GbE Ethernet Adapter
317 - Resolves: bz #296811
318
319 * Wed Sep 19 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
320 - pull new upstream pci.ids, usb.ids
321
322 * Wed Aug 29 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
323 - update license tag
324
325 * Wed Aug 15 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
326 - pull new upstream pci.ids and rebuild
327 - Resolves: bz #251732
328 - Resolves: bz #251734
329 - Resolves: bz #252195
330 - Resolves: bz #252196
331 - Resolves: bz #241274
332
333 * Tue Aug 14 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
334 - add HP TFT5600        #229370
335
336 * Mon Jul 09 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
337 - enable iwl4965 blacklist
338 - Resolves: bz#245379
339
340 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
341 - really update pci.ids, update-pciids downloaded an old file
342 - disable iwl4965 blacklist as it is not approved yet (#245379)
343
344 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.202-1
345 - don't load iwl4965 module automatically
346 - Resolves: #245379
347
348 * Tue Jun 19 2007 Karsten Hopp <karsten@redhat.com> 0.201-1
349 - add some monitors
350 - Resolves: #224511
351 - update pci.ids
352 - Related: #223105
353
354 * Tue Jan 02 2007 Karsten Hopp <karsten@redhat.com> 0.194-1
355 - Update to latest pci.ids/usb.ids for RHEL5
356 - Resolves: #220182
357   Add some Dell monitors to MonitorDB
358
359 * Mon Oct 09 2006 Phil Knirsch <pknirsch@redhat.com> - 0.191-1
360 - Update to latest pci.ids for RHEL5
361
362 * Thu Sep 21 2006 Adam Jackson <ajackson@redhat.com> - 0.190-1
363 - Add a description for the 'intel' driver.
364
365 * Mon Sep 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.189-1
366 - Updated usb.ids for FC6
367
368 * Mon Sep 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.188-1
369 - Update of pci.ids for FC6
370
371 * Thu Aug 31 2006 Adam Jackson <ajackson@redhat.com> - 0.187-1
372 - Fix sync ranges for Samsung SyncMaster 710N (#202344)
373
374 * Thu Aug 03 2006 Phil Knirsch <pknirsch@redhat.com> - 0.186-1
375 - Updated pci.ids once more.
376
377 * Tue Jul 25 2006 Phil Knirsch <pknirsch@redhat.com> - 0.185-1
378 - Added the 17inch Philips LCD monitor entry (#199828)
379
380 * Mon Jul 24 2006 Phil Knirsch <pknirsch@redhat.com> - 0.184-1
381 - Added one more entry for missing Philips LCD monitor (#199828)
382
383 * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.183-1
384 - Updated pci.ids before FC6 final (#198994)
385 - Added several missing Samsung monitors (#197463)
386 - Included a new inf2mondb.py from Matt Domsch (#158723)
387
388 * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> - 0.182-1
389 - Added ast driver description to videodrivers
390 - Numerous Dell monitor additions (#196734)
391 - Numerous Belinea monitor additions (#198087)
392
393 * Sat Jul  8 2006 Adam Jackson <ajackson@redhat.com> - 0.181-1
394 - Updated videodrivers to mention i945
395 - New monitors: Sony CPD-G420 (#145902), Compaq P1110 (#155120).
396
397 * Thu May 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.180-1
398 - Updated and added some MonitorsDB entries
399
400 * Tue May 02 2006 Phil Knirsch <pknirsch@redhat.com> - 0.179-1
401 - Updated PCI ids from upstream (#180402)
402 - Fixed missing monitor entry in MonitorsDB (#189446)
403
404 * Wed Mar 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.178-1
405 - Commented out the VT lines at the end of usb.ids as our tools don't handle
406   them properly.
407
408 * Fri Feb 24 2006 Bill Nottingham <notting@redhat.com> - 0.177-1
409 - remove stock videoaliases in favor of driver-specific ones in
410   the X driver packages
411
412 * Wed Feb 22 2006 Phil Knirsch <pknirsch@redhat.com> - 0.176-1
413 - More entries from Dell to MonitorsDB (#181008)
414
415 * Fri Feb 10 2006 Phil Knirsch <pknirsch@redhat.com> - 0.175-1
416 - Added a few more entries to MonitorsDB
417
418 * Wed Feb 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.174-1
419 - Some cleanup and adds to the MonitorDB which closes several db related bugs.
420
421 * Tue Dec 13 2005 Bill Nottingham <notting@redhat.com> - 0.173-1
422 - add some IDs to the generic display entries for matching laptops
423
424 * Fri Nov 18 2005 Bill Nottingham <notting@redhat.com> - 0.172-1
425 - ditto for radeon
426
427 * Fri Nov 18 2005 Jeremy Katz <katzj@redhat.com> - 0.171-1
428 - r128 -> ati.  should fix the unresolved symbol and kem says its more 
429   generally the "right" thing to do
430
431 * Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 0.170-1
432 - handle mptsas for migration as well
433 - move videoaliases file to a subdir
434
435 * Fri Sep 16 2005 Bill Nottingham <notting@redhat.com>
436 - add Iiyama monitor (#168143)
437
438 * Tue Sep 13 2005 Bill Nottingham <notting@redhat.com>
439 - add IBM monitor (#168080)
440
441 * Thu Sep  8 2005 Bill Nottingham <notting@redhat.com> - 0.169-1
442 - remove Cards, pcitable. Add videodrivers
443
444 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.168-1
445 - Add more Gateway monitors
446
447 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.167-1
448 - Add some ADI monitors, one BenQ, and and DPMS codes for two Apples
449
450 * Fri Sep  2 2005 Bill Nottingham <notting@redhat.com> - 0.166-1
451 - add videoaliases file
452 - remove CardMonitorCombos, as nothing uses it
453
454 * Thu Aug 25 2005 Dan Williams <dcbw@redhat.com> - 0.165-1
455 - Add a bunch of Acer monitors
456
457 * Tue Aug  9 2005 Jeremy Katz <katzj@redhat.com> - 0.164-1
458 - migrate sk98lin -> skge
459
460 * Sat Jul 30 2005 Bill Nottingham <notting@redhat.com>
461 - migrate mpt module names (#161420)
462 - remove pcitable entries for drivers in modules.pcimap
463 - switch lone remaining 'Server' entry - that can't work right
464
465 * Tue Jul 26 2005 Bill Nottingham <notting@redhat.com>
466 - add Daytek monitor (#164339)
467
468 * Wed Jul 13 2005 Bill Nottingham <notting@redhat.com> - 0.162-1
469 - remove /etc/pcmcia/config, conflict with pcmcia-cs
470
471 * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> - 0.160-1
472 - move blacklist to /etc/modprobe.d, require new module-init-tools
473 - add LG monitors (#162466, #161734)
474 - add orinoco card (#161696)
475 - more mptfusion stuff (#107088)
476
477 * Thu Jun 23 2005 Bill Nottingham <notting@redhat.com>
478 - add Samsung monitor (#161013)
479
480 * Wed Jun 22 2005 Bill Nottingham <notting@redhat.com> - 0.159-1
481 - pcitable: make branding happy (#160047)
482 - Cards: add required blank line (#157972)
483 - add some monitors
484 - add JVC CD-ROM (#160907, <richard@rsk.demon.co.uk>)
485 - add hisax stuff to blacklist (#154799, #159068)
486
487 * Mon May 16 2005 Bill Nottingham <notting@redhat.com> - 0.158-1
488 - add a orinoco card (#157482)
489
490 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 0.157-1
491 - add 20" Apple Cinema Display
492
493 * Sun Apr 10 2005 Mike A. Harris <mharris@redhat.com> 0.156-1
494 - Update SiS entries in Cards/pcitable to match what Xorg X11 6.8.2 supports
495
496 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.155-1
497 - Add a boatload of BenQ, Acer, Sony, NEC, Mitsubishi, and Dell monitors
498
499 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.154-1
500 - Add Typhoon Speednet Wireless PCMCIA Card mapping to atmel_cs driver
501
502 * Mon Mar 28 2005 Bill Nottingham <notting@redhat.com> 0.153-1
503 - update the framebuffer blacklist
504
505 * Wed Mar  9 2005 Bill Nottingham <notting@redhat.com> 0.152-1
506 - fix qlogic driver mappings, add upgradelist mappings for the modules
507   that changed names (#150621)
508
509 * Wed Mar  2 2005 Mike A. Harris <mharris@redhat.com> 0.151-1
510 - Added one hundred billion new nvidia PCI IDs to pcitable and Cards to
511   synchronize it with X.Org X11 6.8.2.  (#140601)
512
513 * Tue Jan 11 2005 Dan Williams <dcbw@redhat.com> - 0.150-1
514 - Add Dell UltraSharp 1704FPV (Analog & Digital)
515
516 * Sun Nov 21 2004 Bill Nottingham <notting@redhat.com> - 0.148-1
517 - add Amptron monitors (#139142)
518
519 * Wed Nov 10 2004 Bill Nottingham <notting@redhat.com> - 0.147-1
520 - update usb.ids (#138533)
521 - migrate dpt_i2o to i2o_block (#138603)
522
523 * Tue Nov  9 2004 Bill Nottingham <notting@redhat.com> - 0.146-1
524 - update pci.ids (#138233)
525 - add Apple monitors (#138481)
526
527 * Wed Oct 20 2004 Bill Nottingham <notting@redhat.com> - 0.145-1
528 - remove ahci mappings, don't prefer it over ata_piix
529
530 * Tue Oct 19 2004 Kristian Høgsberg <krh@redhat.com> - 0.144-1
531 - update IDs for Cirrus, Trident, C&T, and S3
532
533 * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> - 0.143-1
534 - add ahci mappings to prefer it over ata_piix
535 - map davej's ancient matrox card to vesa (#122750)
536
537 * Thu Oct  7 2004 Dan Williams <dcbw@redhat.com> - 0.141-1
538 - Add Belkin F5D6020 ver.2 (802.11b card based on Atmel chipset)
539
540 * Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> - 0.140-1
541 - include /etc/hotplug/blacklist here
542
543 * Thu Sep 30 2004 Bill Nottingham <notting@redhat.com> - 0.136-1
544 - add S3 UniChrome (#131403)
545 - update pci.ids
546
547 * Thu Sep 23 2004 Bill Nottingham <notting@redhat.com> - 0.135-1
548 - megaraid -> megaraid_mbox
549
550 * Wed Sep 22 2004 Bill Nottingham <notting@redhat.com> - 0.134-1
551 - map ncr53c8xx to sym53c8xx (#133181)
552
553 * Fri Sep 17 2004 Bill Nottingham <notting@redhat.com> - 0.132-1
554 - fix 3Ware 9000 mapping (#132851)
555
556 * Tue Sep 14 2004 Kristian Høgsberg <krh@redhat.com> - 0.131-1
557 - Add python script to check sorting of pci.ids
558
559 * Thu Sep  9 2004 Kristian Høgsberg <krh@redhat.com> 0.131-1
560 - Add pci ids and cards for new ATI, NVIDIA and Intel cards
561
562 * Sat Sep  4 2004 Bill Nottingham <notting@redhat.com> 0.130-1
563 - trim pcitable - now just ids/drivers
564
565 * Wed Sep  1 2004 Bill Nottingham <notting@redhat.com> 0.125-1
566 - pci.ids updates
567 - remove updsftab.conf.*
568
569 * Sun Aug 29 2004 Mike A. Harris <mharris@redhat.com>  0.124-1
570 - Updates to pcitable/Cards for 'S3 Trio64 3D' cards. (#125866,59956)
571
572 * Fri Jul  9 2004 Mike A. Harris <mharris@redhat.com>  0.123-1
573 - Quick pcitable/Cards update for ATI Radeon and FireGL boards
574
575 * Mon Jun 28 2004 Bill Nottingham <notting@redhat.com>
576 - add Proview monitor (#125853)
577 - add ViewSonic monitor (#126324)
578 - add a Concord camera (#126673)
579
580 * Wed Jun 23 2004 Brent Fox <bfox@redhat.com> - 0.122-1
581 - Add Vobis monitor to MonitorsDB (bug #124151)
582
583 * Wed Jun 09 2004 Dan Williams <dcbw@redhat.com> - 0.121-1
584 - add Belkin F5D5020 10/100 PCMCIA card (#125581)
585
586 * Fri May 28 2004 Bill Nottingham <notting@redhat.com>
587 - add modem (#124663)
588
589 * Mon May 24 2004 Bill Nottingham <notting@redhat.com> - 0.120-1
590 - mainly:
591   fix upgradelist module for CMPci cards (#123647)
592 - also:
593   add another wireless card (#122676)
594   add wireless card (#122625)
595   add 1280x800 (#121548)
596   add 1680x1050 (#121148)
597   add IntelligentStick (#124313)
598
599 * Mon May 10 2004 Jeremy Katz <katzj@redhat.com> - 0.119-1
600 - veth driver is iseries_veth in 2.6
601
602 * Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 0.118-1
603 - add a wireless card (#122064)
604 - and a monitor (#121696)
605
606 * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.117-1
607 - fix makefile
608
609 * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 0.116-1
610 - move updfstab.conf here
611 - add wireless card (#116865)
612 - add laptop display panel (#117385)
613 - add clipdrive (#119928)
614 - add travelling disk (#119143)
615 - add NEXDISK (#106782)
616
617 * Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 0.115-1
618 - replace snd-es1960 driver with snd-es1968 in pcitable (bug #120729)
619
620 * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 0.114-1
621 - fix entries pointing to Banshee (#119388)
622
623 * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.113-1
624 - add a Marvell sk98lin card (#118467, <64bit_fedora@comcast.net>)
625
626 * Fri Mar 12 2004 Brent Fox <bfox@redhat.com> 0.112-1
627 - add a Sun flat panel to MonitorsDB (bug #118138)
628
629 * Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 0.111-1
630 - add Samsung monitor to MonitorsDB (bug #112112)
631
632 * Mon Mar  1 2004 Mike A. Harris <mharris@redhat.com> 0.110-1
633 - Added 3Dfx Voodoo Graphics and Voodoo II entries to the Cards database, both
634   pointing to Alan Cox's new "voodoo" driver which is now included in XFree86
635   4.3.0-62 and later builds in Fedora development.  Mapped their PCI IDs to
636   the new Cards entry in pcitable.
637 - Updated the entries for 3Dfx Banshee
638
639 * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 0.109-1
640 - pci.ids and other updates
641
642 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.108-1
643 - Added Shamrock C407L to MonitorsDB for bug (#104920)
644
645 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.107-1
646 - Massive Viewsonic monitor update for MonitorsDB (#84882)
647
648 * Fri Feb 13 2004 John Dennis <jdennis@finch.boston.redhat.com> 0.106-1
649 - fix typo, GP should have been HP
650
651 * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 0.105-1
652 - many monitor updates (#114260, #114216, #113993, #113932, #113782,
653   #113685, #113523, #111203, #107788, #106526, #63005)
654 - add some PCMCIA cards (#113006, #112505)
655
656 * Tue Jan 20 2004 Bill Nottingham <notting@redhat.com> 0.104-1
657 - switch sound module mappings to alsa drivers
658
659 * Mon Jan 19 2004 Brent Fox <bfox@redhat.com> 0.103-1
660 - fix tab spacing
661
662 * Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.102-1
663 - added an entry for ATI Radeon 9200SE (bug #111306)
664
665 * Sun Oct 26 2003 Jeremy Katz <katzj@redhat.com> 0.101-1
666 - add 1920x1200 Generic LCD as used on some Dell laptops (#108006)
667
668 * Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.100-1
669 - add entry for Sun (made by Samsung) monitor (bug #107128)
670
671 * Tue Sep 23 2003 Mike A. Harris <mharris@redhat.com> 0.99-1
672 - Added entries for Radeon 9600/9600Pro/9800Pro to Cards
673 - Fixed minor glitch in pcitable for Radeon 9500 Pro
674
675 * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
676 - add VMWare display adapter pci id and map to vmware X driver
677
678 * Thu Sep 11 2003 Bill Nottingham <notting@redhat.com> 0.97-1
679 - bcm4400 -> b44
680
681 * Sun Sep  7 2003 Bill Nottingham <notting@redhat.com> 0.96-1
682 - fix provided Dell tweaks (#103892)
683
684 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.95-1
685 - Dell tweaks (#103861)
686
687 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.94-1
688 - add adaptec pci id (#100844)
689
690 * Thu Sep  4 2003 Brent Fox <bfox@redhat.com> 0.93-1
691 - add an SGI monitor for bug (#74870)
692
693 * Wed Aug 27 2003 Bill Nottingham <notting@redhat.com> 0.92-1
694 - updates from sourceforge.net pci.ids, update pcitable accordingly
695
696 * Mon Aug 18 2003 Mike A. Harris <mharris@redhat.com> 0.91-1
697 - Added HP monitors for bug (#102495)
698
699 * Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 0.90-1
700 - added a sony monitor (bug #101550)
701
702 * Tue Jul 15 2003 Bill Nottingham <notting@redhat.com> 0.89-1
703 - updates from modules.pcimap
704
705 * Sat Jul 12 2003 Mike A. Harris <mharris@redhat.com> 0.88-1
706 - Update MonitorsDB for new IBM monitors from upstream XFree86 bugzilla:
707   http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=459
708
709 * Mon Jun  9 2003 Bill Nottingham <notting@redhat.com> 0.87-1
710 - fusion update
711
712 * Mon Jun  9 2003 Jeremy Katz <katzj@redhat.com> 0.86-1
713 - pci id for ata_piix
714
715 * Wed Jun  4 2003 Brent Fox <bfox@redhat.com> 0.85-1
716 - correct entry for Dell P991 monitor
717
718 * Tue Jun  3 2003 Bill Nottingham <notting@redhat.com> 0.84-1
719 - fix qla2100 mapping (#91476)
720 - add dell mappings (#84069)
721
722 * Mon Jun  2 2003 John Dennis <jdennis@redhat.com>
723 - Add new Compaq and HP monitors - bug 90570, bug 90707, bug 90575, IT 17231
724
725 * Wed May 21 2003 Brent Fox <bfox@redhat.com> 0.81-1
726 - add an entry for SiS 650 video card (bug #88271)
727
728 * Wed May 21 2003 Michael Fulbright <msf@redhat.com> 0.80-1
729 - Changed Generic monitor entries in MonitorsDB to being in LCD and CRT groups
730
731 * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 0.79-1
732 - pci.ids and usb.ids updates
733
734 * Tue May  6 2003 Brent Fox <bfox@redhat.com> 0.78-1
735 - added a Samsung monitor to MonitorsDB
736
737 * Fri May  2 2003 Bill Nottingham <notting@redhat.com>
738 - add Xircom wireless airo_cs card (#90099)
739
740 * Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.77-1
741 - add generic framebuffer to Cards
742
743 * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 0.76-1
744 - Updated MonitorsDb for Dell monitors (#86072)
745
746 * Tue Feb 18 2003 Mike A. Harris <mharris@redhat.com> 0.75-1
747 - Change savage MX and IX driver default back to "savage" for the 1.1.27t
748   driver update
749   
750 * Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 0.74-1
751 - Use full resolution description for Dell laptop screens (bug #80398)
752
753 * Thu Feb 13 2003 Mike A. Harris <mharris@redhat.com> 0.73-1
754 - Updated pcitable and Cards database to fix Savage entries up a bit, and
755   change default Savage/MX driver to 'vesa' as it is hosed and with no sign
756   of working in time for 4.3.0.  Fixes (#72476,80278,80346,80423,82394)
757
758 * Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.72-1
759 - slightly alter the sync rates for the Dell 1503FP (bug #84123)
760
761 * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 0.71-1
762 - large pcitable and pci.ids updates
763 - more tg3, e100
764
765 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.69-1
766 - Updated pcitable and Cards database for new Intel i852/i855/i865 support
767
768 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.68-1
769 - Massive update of all ATI video hardware PCI IDs in pcitable and a fair
770   number of additions and corrections to the Cards database as well
771   
772 * Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 0.67-1
773 - change refresh rates of sny0000 monitors to use a low common denominator
774
775 * Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 0.66-1
776 - don't force DRI off on R200 (#82957)
777
778 * Fri Jan 24 2003 Mike A. Harris <mharris@redhat.com> 0.65-1
779 - Added Card:S3 Trio64V2 (Unsupported RAMDAC) entry to pcitable, pci.ids, and
780   Cards database to default this particular variant to "vesa" driver (#81659)
781
782 * Thu Jan  2 2003 Bill Nottingham <notting@redhat.com> 0.64-1
783 - pci.ids and associated pcitable updates
784
785 * Sun Dec 29 2002 Mike A. Harris <mharris@redhat.com> 0.63-1
786 - Updates for GeForce 2 Go, GeForce 4 (#80209)
787
788 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-2
789 - fix Cards for NatSemi Geode
790
791 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-1
792 - use e100 instead of eepro100 for pcmcia
793
794 * Mon Nov 25 2002 Mike A. Harris <mharris@redhat.com>
795 - Complete reconstruction of all Neomagic hardware entries in Cards
796   database to reflect current XFree86, as well as pcitable update,
797   and submitted cleaned up entries to sourceforge
798
799 * Mon Nov  4 2002 Bill Nottingham <notting@redhat.com> 0.61-1
800 - move pcmcia config file here
801 - sort MonitorsDB, add some entries, remove dups
802 - switch some network driver mappings
803
804 * Tue Sep 24 2002 Bill Nottingham <notting@redhat.com> 0.48-1
805 - broadcom 5704 mapping
806 - aic79xx (#73781)
807
808 * Thu Sep  5 2002 Bill Nottingham <notting@redhat.com> 0.47-1
809 - pci.ids updates
810 - add msw's wireless card
811
812 * Tue Sep  3 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
813 - Card entries in pcitable need matching in Cards
814
815 * Sun Sep  1 2002 Mike A. Harris <mharris@redhat.com> 0.45-1
816 - Update G450 entry in Cards
817
818 * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 0.44-1
819 - fix some of the Dell entries
820 - add cardbus controller id (#71198)
821 - add audigy mapping
822 - add NEC monitor (#71320)
823
824 * Tue Aug 13 2002 Preston Brown <pbrown@redhat.com> 0.43-1
825 - pci.id for SMC wireless PCI card (#67346)
826
827 * Sat Aug 10 2002 Mike A. Harris <mharris@redhat.com> 0.42-1
828 - Change default driver for old S3 based "Miro" card for bug (#70743)
829
830 * Fri Aug  9 2002 Preston Brown <pbrown@redhat.com> 0.41-1
831 - fix tabs in pci.ids
832 - Change pci ids for the PowerEdge 4 series again...
833
834 * Tue Aug  6 2002 Preston Brown <pbrown@redhat.com> 0.39-1
835 - Dell PERC and SCSI pci.id additions
836
837 * Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 0.38-1
838 - Removed and/or invalid entries from Cards database BLOCKER (#70802)
839
840 * Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 0.37-1
841 - Changed Matrox G450 driver default options to fix bug (#66697)
842 - Corrected S3 Trio64V2 bug in Cards file (#66492)
843
844 * Tue Jul 30 2002 Bill Nottingham <notting@redhat.com> 0.36-1
845 - tweaks for Dell Remote Assisstant cards (#60376)
846
847 * Fri Jul 26 2002 Mike A. Harris <mharris@redhat.com> 0.35-1
848 - Updated Cards db for CT69000
849 - Various ATI cleanups and additions to Cards and pcitable
850 - Updated S3 Trio3D to default to "vesa" driver (#59956)
851
852 * Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.33-1
853 - Eizo monitor updates (#56080, <triad@df.lth.se>)
854 - pci.ids updates, corresponding pcitable updates
855 - pcilint for pcitable 
856
857 * Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 0.32-1
858 - switch de4x5 back to tulip
859
860 * Mon Jun 24 2002 Mike A. Harris <mharris@redhat.com> 0.31-1
861 - Modified ATI entries in pcitable to be able to autodetect the FireGL 8700
862   and FireGL 8800 which both have the same ID, but different subdevice ID's.
863   Added entries to Cards database for the 8700/8800 as well.
864
865 * Tue May 28 2002 Mike A. Harris <mharris@redhat.com> 0.30-1
866 - Reconfigured Cards database to default to XFree86 4.x for ALL video
867   hardware, since 3.3.6 support is being removed.  Video cards not
868   supported natively by 4.x will be changed to use the vesa or vga
869   driver, or completely removed as unsupported.
870
871 * Wed Apr 17 2002 Michael Fulbright <msf@redhat.com> 0.14-1
872 - another megaraid variant
873
874 * Mon Apr 15 2002 Michael Fulbright <msf@redhat.com> 0.13-1
875 - fix monitor entry for Dell 1600X Laptop Display Panel
876
877 * Fri Apr 12 2002 Bill Nottingham <notting@redhat.com> 0.13-1
878 - more aacraid
879
880 * Tue Apr  9 2002 Bill Nottingham <notting@redhat.com> 0.12-1
881 - another 3ware, another megaraid
882
883 * Fri Apr  5 2002 Mike A. Harris <mharris@redhat.com> 0.11-1
884 - Added commented out line for some Radeon 7500 cards to Cards database.
885
886 * Tue Apr  2 2002 Mike A. Harris <mharris@redhat.com> 0.10-1
887 - Fixed i830 entry to use driver "i810" not "i830" which doesn't exist
888
889 * Mon Apr  1 2002 Bill Nottingham <notting@redhat.com> 0.9-1
890 - fix rebuild (#62459)
891 - SuperSavage ids (#62101)
892 - updates from pci.ids
893
894 * Mon Mar 18 2002 Bill Nottingham <notting@redhat.com> 0.8-2
895 - fix errant space (#61363)
896
897 * Thu Mar 14 2002 Bill Nottingham <notting@redhat.com> 0.8-1
898 - nVidia updates
899
900 * Wed Mar 13 2002 Bill Nottingham <notting@redhat.com> 0.7-1
901 - lots of pcitable updates
902
903 * Tue Mar  5 2002 Mike A. Harris <mharris@redhat.com> 0.6-1
904 - Updated Cards database
905
906 * Mon Mar  4 2002 Mike A. Harris <mharris@redhat.com> 0.5-1
907 - Built new package with updated database files for rawhide.
908
909 * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 0.3-1
910 - return of XFree86-3.3.x
911
912 * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 0.1-1
913 - initial build